本文へ移動

基本情報技術者 科目A 想定問題集

技術要素の要点整理と想定問題

公式のシラバスの「テクノロジ系 大分類 3:技術要素(中分類 7〜11)」にあたる分野です。まず要点整理で全体をつかみ、下の演習で 105 問を 1 問ずつ解けます。答えると A〜D すべての解説が出ます。

この分野の小項目

  • 7-1, 7-2, 8-1, 8-2 ユーザーインタフェースと情報メディア(8 問) 情報アーキテクチャ、UI・GUI の種類と特徴、UX/UI デザイン(画面設計・帳票設計・コード設計・人間中心設計・ユニバーサルデザイン・ユーザビリティ評価)、マルチメディア技術(音声・静止画・動画・情報の圧縮と伸長)とその応用を理解し、担当する事項に適用する。
  • 9-1 データベース方式(6 問) データベースの種類と特徴、データベースのモデル、3 層スキーマの考え方、データベース管理システムの目的と代表的な機能を理解し、担当する事項に適用する。
  • 9-2 データベース設計と正規化(6 問) データ分析とデータベース設計の考え方(E-R 図など)、データの正規化の目的と手順、データベースの物理設計における留意事項を理解し、担当する事項に適用する。
  • 9-3 データ操作と SQL(7 問) 関係データベースの代表的なデータ操作(選択・射影・結合などの関係演算)と、代表的なデータベース言語・SQL 文の基本を理解し、担当する事項に適用する。
  • 9-4 トランザクション処理(6 問) 同時実行制御(排他制御)、障害回復(ロールバック・ロールフォワードなど)、トランザクション管理、データベースの性能向上、データへのアクセス制御の基本的な仕組みを理解し、担当する事項に適用する。
  • 9-5 データベース応用(5 問) データ分析や業務システムなどへのデータベースの応用(データウェアハウス・データレイク・NoSQL など)、分散データベースの特徴とデータ同期の仕組み、データ資源管理のあらましを理解する。
  • 10-1 ネットワーク方式(6 問) LAN と WAN、有線 LAN と無線 LAN、交換方式の仕組みと特徴、回線速度・データ量・転送時間の関係(回線に関する計算)、インターネット技術を理解し、担当する事項に適用する。
  • 10-2 データ通信と制御(6 問) ネットワークアーキテクチャ(OSI 基本参照モデルなど)、伝送方式と回線、ネットワーク接続装置(ルータ・スイッチなど)、伝送制御、メディアアクセス制御の基本的な仕組みと特徴を理解し、担当する事項に適用する。
  • 10-3 通信プロトコル(8 問) 代表的なプロトコルである TCP/IP の各プロトコル(IP・TCP・UDP・HTTP・DNS・DHCP など)が、OSI 基本参照モデルのどの階層の機能を実現しているかを理解し、担当する事項に適用する。
  • 10-4, 10-5 ネットワーク管理と応用(6 問) ネットワーク運用管理の管理項目とツール(SNMP など)、仮想ネットワーク、電子メールや Web などインターネットの仕組み、イントラネットとエクストラネット、通信サービス、モバイルシステムのあらましを理解する。
  • 11-1 情報セキュリティの目的と脅威・攻撃手法(8 問) 情報セキュリティの目的と考え方(機密性・完全性・可用性など)、脅威と脆弱性、不正のメカニズム、攻撃者の種類と動機、主な攻撃手法(マルウェア・ソーシャルエンジニアリング・SQL インジェクションなど)を理解する。
  • 11-1 暗号・認証などの情報セキュリティ技術(8 問) 情報システムを開発する上で必要な情報セキュリティに関する技術(共通鍵暗号方式・公開鍵暗号方式・ハッシュ関数・ディジタル署名・PKI・利用者認証など)を理解し、担当する事項に適用する。
  • 11-2 情報セキュリティ管理(7 問) 情報セキュリティ管理の基本的な考え方、リスク分析と評価の方法と手順、情報セキュリティ継続、情報セキュリティポリシーなどの諸規程、ISMS の仕組み、情報セキュリティ組織・機関(CSIRT など)の活動、情報セキュリティに関する基準を理解する。
  • 11-3, 11-4 セキュリティ技術評価と情報セキュリティ対策(8 問) セキュリティ技術の評価の基本的な考え方(セキュリティ評価基準)と、人的・技術的・物理的セキュリティの側面からの情報セキュリティ対策を理解し、担当する事項に適用する。
  • 11-5 セキュリティ実装技術(10 問) セキュアプロトコル(TLS など)、認証・認可技術、ネットワークセキュリティ(ファイアウォール・WAF・DMZ など)、データベースセキュリティ、アプリケーションセキュリティの対策のあらましを理解する。

要点整理

ユーザーインタフェースと情報メディア

画面は「入力チェック」「コード」「誰でも使える」、メディアは「形式と計算」で覚える

画面設計では入力チェックの名前と中身を対で覚えます。数字だけかを見るのがニューメリックチェック、範囲に収まるかを見るのがリミットチェック、マスタに登録済みかを見るのが照合チェックです。

コード設計では、通し番号の順番コード、番号の範囲で分ける区分コード、桁の位置に意味を持たせる桁別コード、見て意味が分かる表意コードを区別します。

アクセシビリティは、誰もが情報を使えるようにする考え方です。WCAG 2.2 は、色だけで情報を伝えないこと、すべての機能をキーボードで操作できることなどを求めています。マウス操作が前提になりがちな GUI でも、キーボードだけで使えるようにします。年齢や障害の有無にかかわらず、できるだけ多くの人が使いやすいように設計する考え方はユニバーサルデザインです。

使いやすさの評価には、専門家が経験則で点検するヒューリスティック評価と、利用者に操作してもらうユーザビリティテストがあります。人間中心設計は、利用状況の理解、要求の明確化、設計、利用者による評価を繰り返す進め方です。

メディアでは、写真は JPEG(非可逆圧縮)、文字や線の多い図は PNG(可逆圧縮・透明度あり)、ロゴはベクターデータと選び分けます。

音声の PCM のデータ量は「標本化周波数 × 量子化ビット数 × 秒数 ÷ 8」バイトです。8 kHz・16 ビット・1 分なら 960,000 バイトになります。

やりたいこと選ぶもの見分けるポイント
月に 13 が入るのを防ぐリミットチェック値の範囲を見る
桁ごとに事業所・部署を表す桁別コード桁の位置に意味がある
専門家が経験則で画面を点検ヒューリスティック評価利用者を集めない
写真を小さく保存JPEG非可逆圧縮
図や画面写しを劣化なく保存PNG可逆圧縮・透明度あり
ロゴを大きく印刷ベクターデータ拡大しても輪郭がなめらか

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/W3C WCAG 2.2/W3C PNG Specification (Third Edition)

データベース方式

3 層スキーマとデータベースの種類を選び分ける

3 層スキーマは、利用者ごとの見え方(外部スキーマ)、全体の論理構造(概念スキーマ)、物理的な格納(内部スキーマ)を分けます。格納方法を変えてもアプリを直さずに済むのは、この分離のおかげです。

関係データベースでは、表の 1 行をタプル、列を属性、属性が取りうる値の集合を定義域(ドメイン)と呼びます。

DBMS には、構造を決める定義機能、データを出し入れする操作機能、同時実行制御や障害回復を行う制御機能、アクセスを制限する機密保護機能があります。

NoSQL は用途で選びます。キーで 1 件を素早く出し入れするならキーバリュー型データベース、関係をたどるならグラフデータベース、JSON のような文書をそのまま持つならドキュメント指向です。

用途向く方式特徴
会計など表で整理できる業務関係データベース表と SQL で操作
買い物かご・セッション情報キーバリュー型データベースキーで素早く読み書き
SNS の友人関係・推薦グラフデータベース点と線で関係をたどる
商品カタログ・利用者プロフィールドキュメント指向JSON 風の文書を柔軟に保存

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/AWS NoSQL データベースとは/AWS「キーバリューデータベースとは」

データベース設計と正規化

E-R 図と正規化は「何で決まるか」を見る

E-R 図では、1 対 1、1 対多、多対多の関係を表します。多対多は、そのままでは表にできません。両方の主キーを外部キーとして持つ「履修」のような表を間に置き、1 対多 2 つに分けます。

正規化は、重複と矛盾をなくすために表を分ける手順です。1 つの欄に複数の値があれば分けて第 1 正規形にします。主キーの一部だけで決まる部分関数従属をなくすと第 2 正規形、主キー以外の項目を介して決まる推移関数従属をなくすと第 3 正規形です。

物理設計ではディスク容量を見積もります。1 ブロックに入る件数は「ブロックの大きさ ÷ 1 件の大きさ」の小数点以下を切り捨てた数です。全件数をそれで割り、端数は切り上げます。

見つけた状態名前直した後
1 つの欄に電話番号が 2 つ繰返し項目第 1 正規形
{受注番号, 商品番号} の一部で商品名が決まる部分関数従属第 2 正規形
社員番号→部署コード→部署名推移関数従属第 3 正規形

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/PostgreSQL 文書 Constraints

データ操作と SQL

関係演算と SQL の句の役割をそろえて覚える

関係演算では、行を選ぶのが選択、列を選ぶのが射影、表をつなぐのが結合です。集合演算は、和が UNION、積(共通部分)が INTERSECT、差が EXCEPT です。どれも、既定では重複した行を除きます。

WHERE は集計の前に行を選び、HAVING は GROUP BY で集計した後のグループを選びます。WHERE に集約関数は書けません。全体の平均と比べたいときは副問合せで先に平均を求めます。

権限は GRANT で与え、REVOKE で取り消します。見るだけなら SELECT 権限だけを与えます。

他の表に無い値の登録を防ぐのは参照制約(外部キー)、重複を防ぐのは一意性制約、空値を防ぐのは非 NULL 制約、値の条件を見るのは検査制約です。

1 つの表から行を絞っただけのビューは、ビューを通して更新できます。GROUP BY・DISTINCT・UNION を含むビューは、元の行と対応しないため更新できません。

やりたいこと使う SQL・制約
部署ごとの平均で絞るGROUP BY … HAVING AVG(…)
全体の平均より高い行WHERE 列 > (SELECT AVG(…) …)
両方の表にいる行INTERSECT
見るだけ許可するGRANT SELECT
存在しない番号を防ぐ参照制約(外部キー)

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/PostgreSQL 文書 Aggregate Functions/PostgreSQL 文書 Combining Queries/PostgreSQL 文書 CREATE VIEW

トランザクション処理

ロック・障害回復・インデックスは場面で選ぶ

トランザクションが満たすべき ACID 特性は、原子性(全部か無しか)、一貫性、独立性、耐久性の 4 つです。振替の途中で止まったら全部取り消すのは原子性の要求です。

読むときの共有ロックどうしは同時にかけられます。更新のための専有ロックは、他のどのロックとも両立しません。2 つの処理が逆の順序でロックを取るとデッドロックが起きます。全処理でロックの順序をそろえるのが基本の対策です。

障害回復は種類で手順が変わります。未コミットの処理は更新前の記録でロールバックします。ディスクが壊れたら、バックアップを戻してから更新後の記録でロールフォワードします。チェックポイントは回復を始める起点です。

範囲検索や並べ替えには B-tree のインデックスが向きます。ハッシュは等しい値の検索専用です。インデックスを増やしすぎると、更新のたびに索引も直すため遅くなります。

起きたこと回復の手順
処理の途中で失敗した更新前の記録でロールバック
停電。コミット済みの更新がディスクに未反映更新後の記録でロールフォワード
停電。コミット前の処理があった更新前の記録でロールバック
ディスクが壊れたバックアップを戻してロールフォワード

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/PostgreSQL 文書 Explicit Locking/PostgreSQL 文書 Write-Ahead Logging/PostgreSQL 文書 Index Types/Oracle Database 19c 概要(インスタンス・リカバリ)

データベース応用

分析のためのデータの置き場と、分散データベースの確定のしかた

データウェアハウスは、分析用に整えたデータを決めた構造で蓄えます。データレイクは、形式を問わず元のまま蓄えます。部門別に切り出した分析用データはデータマートと呼びます。

OLAP は多次元の集計です。細かく掘り下げるのがドリルダウン、まとめるのがロールアップ、断面を切り出すのがスライスです。日々の取引を処理する OLTP と対で覚えます。

ETL は変換してから書き込み、ELT は先に書き込んでから分析基盤の上で変換します。

分散データベースで複数サイトの更新を 1 つにまとめるには2 相コミットメントを使います。全員に準備ができたかを確かめ、全員が可なら一斉に確定します。複製を作って同期するレプリケーションとは目的が違います。

データ項目の意味や型などのメタデータは、データディクショナリにまとめて管理します。

言葉ひと言で混同しやすい相手
データレイク元のまま何でも貯めるデータウェアハウス(整えて貯める)
ドリルダウン細かく掘り下げるロールアップ(まとめる)
ELT書き込んでから変換ETL(変換してから書き込む)
2 相コミットメント全サイトそろって確定レプリケーション(複製の同期)

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/AWS データレイクとは/AWS OLAP とは/AWS ETL とは

ネットワーク方式

LAN・WAN と交換方式、回線の計算

LAN は建物や敷地の中のネットワーク、WAN は通信事業者の回線などで離れた拠点を結ぶネットワークです。

回線交換は経路を専有するので品質が安定します。パケット交換はデータを分けて送り、回線を共有するので効率が高くなります。IP 電話(VoIP)は音声をパケットにして送ります。

転送時間は「データ量(ビット)÷ 実際に使える速度」です。バイトは 8 倍してビットに直し、速度には回線利用率を掛けます。呼量は通話時間の合計を観測時間で割り、単位はアーランです。

プライベート IP アドレスは、10.0.0.0/8・172.16.0.0/12・192.168.0.0/16 の範囲です(RFC 1918)。NAPT はポート番号も変換し、1 つのグローバルアドレスを多くの端末で共有させます。

無線 LAN の家庭用ルータでは、総務省の手引きが WPA2 か WPA3 を選ぶよう勧めています。WEP など解読方法が知られた古い方式は避けます。

計算式例
転送時間データ量 × 8 ÷(速度 × 利用率)300 M バイト → 2,400 ÷ 60 = 40 秒
呼量通話時間の合計 ÷ 観測時間60 件 × 3 分 ÷ 60 分 = 3 アーラン
PCM の 1 秒分標本化周波数 × 量子化ビット数8,000 × 16 = 128 k ビット

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/RFC 1918/RFC 3022 Traditional NAT/総務省 自宅 Wi-Fi 利用者向け簡易マニュアル

データ通信と制御

OSI の層と接続装置、アクセス制御を対応させる

OSI 基本参照モデルは下から物理層、データリンク層、ネットワーク層、トランスポート層、セション層、プレゼンテーション層、アプリケーション層の 7 層です。

接続装置は働く層で覚えます。リピータは物理層、スイッチングハブ(L2 スイッチ)とブリッジはデータリンク層、ルータはネットワーク層です。ゲートウェイはプロトコルの違うネットワークを変換してつなぎます。

通信の向きは、片方向だけの単方向、交互に切り替える半二重、同時に送受信できる全二重の 3 つです。

有線のイーサネットで使われてきた CSMA/CD は衝突を検知して送り直します。無線 LAN の CSMA/CA は、送る前に待って衝突を避けます。

スター型は中央の集線装置に各端末をつなぐ形で、中央が止まると全体が止まります。内部から外へ出るときの代理がプロキシサーバ、外部からの要求を受けて内部へ中継するのがリバースプロキシです。

装置働く層見るもの
リピータ物理層信号(宛先は見ない)
スイッチングハブデータリンク層MAC アドレス
ルータネットワーク層IP アドレス
リバースプロキシアプリケーション層HTTP などの要求

出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/ISO/IEC 7498-1:1994 OSI Basic Reference Model

通信プロトコル

通信プロトコル:どの層で何をするかを対で覚える

TCP/IP のプロトコルは、OSI 基本参照モデルのどの層の働きをするかで整理すると覚えやすくなります。

トランスポート層の TCP は、SYN・SYN と ACK・ACK の 3 回のやり取りで接続を確立し、確認応答と再送で確実に届けます。UDP は接続を確立せず、配達や重複の防止を保証しません。その分、手順が軽くなります。どちらも 16 ビットのポート番号でアプリケーションを区別します。

ネットワーク層では、IP の一部である ICMP が通信の問題を知らせます。ping の応答や、TTL が尽きたときの時間超過の通知に使われます。シラバスがデータリンク層のプロトコルに挙げる ARP は、IP アドレスから同じ LAN の相手の MAC アドレスを求めます。問い合わせはブロードキャストで送ります。

CIDR では「/26」のようにネットワーク部の長さを自由に決めます。ホスト部が n ビットなら、機器に使えるのは 2^n−2 個です(ネットワークアドレスとブロードキャストアドレスを除く)。IPv6 はアドレスを 128 ビットに広げました。

アプリケーション層では、DHCP が DISCOVER・OFFER・REQUEST・ACK の順で設定を配ります。DNS はポート 53 を使い、MX レコードでメールの配送先を示します。HTTP/3 は UDP を使う QUIC の上で動きます。HTTPS は HTTP の通信を TLS で暗号化し、盗聴や改ざんを防ぎます。

プロトコル主な層覚える点
TCPトランスポート層接続を確立・確認応答と再送で確実に届ける
UDPトランスポート層接続なし・配達の保証なし・遅れが少ない
ICMPネットワーク層エラーの通知・ping・時間超過
ARPデータリンク層(シラバスの分類)IP アドレスから MAC アドレスを求める
DHCPアプリケーション層IP アドレスなどの設定を自動で配る
DNSアプリケーション層名前と IP アドレスの対応・MX でメールの配送先

出典: RFC 9293 Transmission Control Protocol (TCP)/RFC 768 User Datagram Protocol/RFC 792 Internet Control Message Protocol/RFC 826 An Ethernet Address Resolution Protocol/RFC 2131 Dynamic Host Configuration Protocol/RFC 1035 Domain Names - Implementation and Specification/RFC 8200 Internet Protocol, Version 6 (IPv6) Specification/RFC 9114 HTTP/3/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

ネットワーク管理と応用

ネットワーク管理と応用:監視の道具とメールの流れ

SNMP では、管理サーバ(マネージャ)が機器のエージェントに問い合わせ、機器の情報は MIB にまとめられています。異常が起きたときは、エージェントが問合せを待たずにトラップで知らせます。

経路の調べ方も出ます。ping は ICMP のエコー要求で相手に届くかを確かめます。traceroute は TTL を 1 から順に増やして送り、時間超過の通知から経路上のルータを順に特定します。

メールは、送信と転送に SMTP、受信に POP3 か IMAP を使います。POP3 はメールを端末に取り込む方式で、IMAP はサーバ上のメールボックスを遠隔で扱います。複数の端末で同じ状態を見たいなら IMAP です。

SDN は、ネットワーク機器の転送の動きをソフトウェアから集中して制御する考え方で、OpenFlow が代表例です。VPN は、インターネットなどを通して拠点の間を専用線のようにつなぎます。

移動通信では、無線局を自ら開設・運用する事業者を MNO、それを利用してサービスを提供し無線局を持たない事業者を MVNO と呼びます。

やりたいこと使うもの
機器の状態を集めて監視するSNMP(異常はトラップで通知)
相手に届くかを確かめるping(ICMP のエコー)
経路上のどのルータかを調べるtraceroute(TTL と時間超過)
メールをサーバ間で転送するSMTP
複数の端末で同じメールを読むIMAP
ネットワークをソフトウェアで集中制御するSDN

出典: RFC 3411 An Architecture for Describing SNMP Management Frameworks/RFC 1393 Traceroute Using an IP Option/RFC 5321 Simple Mail Transfer Protocol/RFC 9051 Internet Message Access Protocol (IMAP) - Version 4rev2/RFC 1939 Post Office Protocol - Version 3/移動通信サービス等の区分の定義(総務省 資料)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

情報セキュリティの目的と脅威・攻撃手法

情報セキュリティの目的と、攻撃の名前の見分け方

情報セキュリティの基本は 3 つの要素です。機密性は許可された人だけが見られること、完全性は情報が正確で欠けていないこと、可用性は必要なときに使えることです。暗号化は機密性、改ざんの検出は完全性、二重化は可用性に効きます。

攻撃の名前は「何を手がかりにするか」で見分けます。漏れた ID とパスワードを別のサービスで試すのはパスワードリスト攻撃、候補を全部試すのはブルートフォース攻撃です。修正プログラムが出る前の脆弱性を突くのはゼロデイ攻撃です。

特定の組織を狙い、業務を装ったメールで入り込むのが標的型攻撃です。通信の間に割り込むのが中間者攻撃、DNS に偽の情報を覚えさせて偽サイトへ誘うのが DNS キャッシュポイズニングです。

内部不正は不正のトライアングルで考えます。動機(プレッシャー)・機会・正当化の 3 つがそろうと不正が起きやすいとされ、IPA は 3 つを減らすことを勧めています。IPA の「情報セキュリティ 10 大脅威 2026」組織編の 1 位は「ランサム攻撃による被害」です。

手がかり攻撃の名前
他のサイトで漏れた ID とパスワードパスワードリスト攻撃
パスワードの候補を全部試すブルートフォース攻撃
修正プログラムがまだ無いゼロデイ攻撃
URL に「../」ディレクトリトラバーサル
正しい URL なのに偽サイトDNS キャッシュポイズニング
特定の部署に業務を装ったメール標的型攻撃

出典: 国民のためのサイバーセキュリティサイト 用語集(か行)(総務省)/安全なパスワードの設定・管理(総務省)/脆弱性(ぜいじゃくせい)とは?(総務省)/国民のためのサイバーセキュリティサイト 用語集(英字)(総務省)/IPA NEWS Vol.64(2023 年 12 月号)/情報セキュリティ 10 大脅威 2026(IPA)

暗号・認証などの情報セキュリティ技術

暗号と認証:鍵の数と、どの鍵で何をするか

共通鍵暗号方式は暗号化と復号に同じ鍵を使い、公開鍵暗号方式は異なる鍵を使います。n 人が互いに通信するとき、共通鍵は n(n−1)/2 個、公開鍵暗号は 1 人 1 組で 2n 個の鍵が要ります。10 人なら 45 個と 20 個です。

ハイブリッド暗号は、データを速い共通鍵で暗号化し、その共通鍵を受信者の公開鍵で暗号化して渡します。ディジタル署名は送信者の秘密鍵で作り、送信者の公開鍵で検証します。HMAC などのメッセージ認証符号は共有鍵を使うので、改ざんは見つけられますが、第三者への否認防止はできません。

PKI(公開鍵基盤)では、認証局が発行する電子証明書で公開鍵の持ち主を保証します。証明書を期限前に無効にしたかは、CRL を見るか OCSP で問い合わせて確かめます。パスワードの保存では、利用者ごとにソルトを加えてからハッシュ値にします。チャレンジレスポンス認証は、パスワードそのものを回線に流しません。

生体認証の精度は他人受入率と本人拒否率で表します。しきい値を厳しくすると他人受入率は下がりますが、本人拒否率は上がります。

やりたいこと使う鍵・方式
相手だけが読めるように送る受信者の公開鍵で暗号化
大きなデータを速く安全に送るハイブリッド暗号
送信者を第三者にも示す送信者の秘密鍵でディジタル署名
共有鍵で改ざんを見つけるメッセージ認証符号(HMAC など)
証明書の失効を確かめるCRL・OCSP
保存したパスワードを守るソルトを加えてハッシュ値にする

出典: 国民のためのサイバーセキュリティサイト 用語集(か行)(総務省)/国民のためのサイバーセキュリティサイト 用語集(た行)(総務省)/RFC 5652 Cryptographic Message Syntax (CMS)/RFC 5280 Internet X.509 PKI Certificate and CRL Profile/RFC 8018 PKCS #5: Password-Based Cryptography Specification Version 2.1/情報漏えいを防ぐためのモバイルデバイス等設定マニュアル 解説編(IPA)

情報セキュリティ管理

情報セキュリティ管理:リスク値とリスク対応の 4 つ

IPA の中小企業向けの手法では、情報資産の重要度を機密性・完全性・可用性の評価値の最大値で決めます。リスク値は「重要度×被害発生可能性」で求め、値の大きい資産から対策します。

リスク対応には 4 つあります。対策で起こりやすさを下げるのがリスク低減、原因の活動をやめるのがリスク回避、保険や外部サービスで負担を移すのがリスク移転、影響が小さいなどの理由で受け入れるのがリスク保有です。対策の後に残るリスクは残留リスクと呼ばれます。

情報セキュリティポリシーは、3 つの要素を守るための組織の方針や行動指針をまとめたものです。ISMS の認証は、ISMS-AC が認定した認証機関が JIS Q 27001(ISO/IEC 27001)を基準に審査します。

インシデントには CSIRT が対応します。アクセス権は、仕事に必要な範囲だけを与える最小権限(need-to-know)の原則で決め、異動や退職のたびに見直します。

リスク対応例
リスク低減マルウェア対策ソフトを入れる・外部記憶媒体の接続を制限する
リスク回避機密情報のサーバを外部に接続しない
リスク移転保険に入る・対策の充実したクラウドサービスへ移す
リスク保有影響が小さい資産は対策せず現状を維持する

出典: リスク分析シート 説明資料(IPA)/国民のためのサイバーセキュリティサイト 用語集(さ行)(総務省)/ISMS 適合性評価制度の概要(ISMS-AC)/CSIRT マテリアル(JPCERT/CC)/アクセス制御・管理(総務省)

セキュリティ技術評価と情報セキュリティ対策

評価の基準と対策製品:検査の違いと誤検知

製品のセキュリティを評価・認証する国際基準は ISO/IEC 15408(コモンクライテリア)で、日本では JISEC が運用しています。脆弱性の深刻度は CVSS で 0.0〜10.0 の数値にします。CVSS v3 は、脆弱性そのものの基本評価基準、今の状況の現状評価基準、利用者の環境の環境評価基準の 3 つです。

脆弱性診断はシステム全体を網羅的に調べて弱点を探し、ペネトレーションテストは攻撃者の視点で攻撃が成功するかを確かめます。耐タンパ性は、装置の中の鍵などが外部からの解読攻撃に耐える性質です。

ファイアウォールは規則に従って通信を許可・遮断し、外部に公開するサーバは内部と分けた DMZ に置きます。IDS は不正な侵入を検知し、IPS はさらに通信を遮断します。検知の定義を広く取るとフォールスポジティブ(誤検知)が増え、狭く絞るとフォールスネガティブ(検知漏れ)が増えます。多数の機器のログは SIEM で集めて相関分析します。

ランサムウェアに備えるバックアップは、本番と同じネットワークに置かず、オフラインでも保管し、戻す訓練をしておきます。

名前何をするか
IDS不正な侵入を検知して知らせる
IPS検知に加えて通信を遮断する
SIEMログを集めて相関分析する
脆弱性診断弱点を網羅的に洗い出す
ペネトレーションテスト実際に攻撃が成功するかを確かめる
CVSS脆弱性の深刻度を数値で表す

出典: IT セキュリティ評価及び認証制度(JISEC)について(IPA)/共通脆弱性評価システム CVSS v3 概説(IPA)/脆弱性診断・ペネトレーションテスト(総務省)/産業用制御システム向け侵入検知製品等の導入手引書(IPA)/政府機関等の対策基準策定のためのガイドライン(令和 7 年度版)(国家サイバー統括室)/データ復旧・バックアップの管理(総務省)

セキュリティ実装技術

セキュリティ実装技術:攻撃ごとの根本的な対策

Web アプリの攻撃には、IPA が「根本的な解決」として示す対策を対で覚えます。SQL インジェクションにはプレースホルダ、クロスサイトスクリプティングには出力時のエスケープ処理、クロスサイトリクエストフォージェリには推測されにくい秘密情報の埋め込みと照合です。エラーメッセージを出さない、Cookie に HttpOnly を付けるなどは保険的な対策です。

なりすましメールには送信ドメイン認証を使います。SPF は送信元の IP アドレス、DKIM は電子署名で確かめ、DMARC は両者の結果をもとに隔離・拒否などの方針を DNS で示します。DNSSEC は DNS の応答に署名を付けますが、内容の秘匿はしません。

IPsec のトンネルモードはパケット全体を包み、拠点間の VPN に使います。NAPT はアドレスとポート番号を変換し、多くの機器で 1 つのグローバルアドレスを共有します。OAuth はパスワードの代わりにアクセストークンで限られた権限を与えます。無線 LAN は WPA3 か WPA2 を使い、WEP は使いません。

攻撃・課題根本的な対策・使う技術
SQL インジェクションプレースホルダで SQL 文を組み立てる
クロスサイトスクリプティング出力するすべての要素をエスケープする
クロスサイトリクエストフォージェリ秘密情報を埋め込み照合する
送信ドメインのなりすましSPF・DKIM・DMARC
DNS 応答の改ざんDNSSEC
アプリに限られた権限を渡すOAuth

出典: 安全なウェブサイトの作り方 1.1 SQL インジェクション(IPA)/安全なウェブサイトの作り方 1.5 クロスサイト・スクリプティング(IPA)/安全なウェブサイトの作り方 1.6 CSRF(IPA)/電子メールと Web サイトにおける対策(総務省)/RFC 9989 Domain-Based Message Authentication, Reporting, and Conformance (DMARC)/RFC 4033 DNS Security Introduction and Requirements/RFC 4301 Security Architecture for the Internet Protocol/RFC 6749 The OAuth 2.0 Authorization Framework/安全な無線 LAN の利用(総務省)

演習(105 問)

結果はこのブラウザに保存され、ハブの「自分の成績」と弱点モードに使われます。

第 1 問 / 105 問

問題を読み込んでいます…

全問と解説の一覧

正解と解説は折りたたんであります。先に自分で考えてから開いてください。

全 105 問

ユーザーインタフェースと情報メディア

  1. 会員登録画面で、生年月日の「月」に 13 が入力されたら警告を出したい。この入力チェックとして最も適切なものは?

    A. ニューメリックチェック B. リミットチェック C. 照合チェック D. バランスチェック

    答えと解説

    正解: B 【A(不正解)】 ? 入力が数字だけでできているかを調べるチェックです。 13 は数字なので、このチェックでは止められない。値の範囲までは見ない。 【B(正解)】 ? 入力値があらかじめ決めた上限・下限の範囲に収まるかを調べるチェックです。 月は 1〜12 の範囲に収まる必要がある。範囲外の 13 を見つけるのはこのチェックである。 【C(不正解)】 ? 入力値がマスタなどに登録済みの値と一致するかを調べるチェックです。 登録済みのコードとの突き合わせに使う。月の範囲を確かめる目的には合わない。 【D(不正解)】 ? 借方と貸方の合計など、対になる値の釣り合いを調べるチェックです。 会計データなどの合計の一致を確かめる方法で、1 つの値の範囲は見ない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. 社員コード「31205」を、先頭 1 桁が事業所、次の 2 桁が部署、残り 2 桁が部署内の連番になるように決めた。このコードの種類は?

    A. 順番コード B. 表意コード C. 区分コード D. 桁別コード

    答えと解説

    正解: D 【A(不正解)】 ? 対象に 1 から順に番号を振っていくコードです。 通し番号だけでは桁ごとの意味を持たない。事業所や部署を桁で表す今回とは違う。 【B(不正解)】 ? 略語などを使い、コードを見ただけで内容が分かるようにしたコードです。 「TV-32」のように意味を読み取れる形のコードを指す。数字の桁で区分する今回とは違う。 【C(不正解)】 ? 番号の範囲ごとにグループを割り当てるコードです。 例えば 100〜199 を営業部に割り当てる方式を指す。桁の位置ごとに意味を持たせる形ではない。 【D(正解)】 ? コードの各桁(または桁のまとまり)にそれぞれ意味を持たせるコードです。 先頭 1 桁が事業所、次の 2 桁が部署のように、桁の位置で意味を分けている。これが桁別コードである。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  3. 申込フォームで、入力が必須の項目の見出しを赤い文字にするだけで示している。アクセシビリティの観点で最も適切な改善は?

    A. 「必須」の文字や記号も添え、色以外でも分かるようにする B. 赤をもっと鮮やかな赤に変えて目立たせる C. 必須の項目を画面の下のほうにまとめる D. 見出しの文字を小さくして画面を広く見せる

    答えと解説

    正解: A 【A(正解)】 ? 色に頼らない手がかりを加える改善です。 WCAG 2.2 の達成基準 1.4.1 は、色だけを情報を伝える唯一の手段にしないよう求めている。 【B(不正解)】 ? 色の強さを上げる改善です。 色の違いが分かりにくい人には、どれだけ鮮やかでも伝わらない。色だけに頼る問題は残る。 【C(不正解)】 ? 項目の並び順を変える改善です。 並び順を変えても、どの項目が必須かを色以外で示したことにはならない。 【D(不正解)】 ? 画面の余白を増やす改善です。 文字を小さくすると読みにくくなるおそれがあり、必須の伝え方の問題も解決しない。

    出典: W3C Web Content Accessibility Guidelines (WCAG) 2.2/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. 新しい予約画面を公開前に点検したい。UI の専門家 3 人が、よく知られた設計の経験則に照らして問題点を洗い出す方法は?

    A. ユーザビリティテスト B. 負荷テスト C. ヒューリスティック評価 D. 満足度アンケート

    答えと解説

    正解: C 【A(不正解)】 ? 実際の利用者に課題を操作してもらい、つまずく様子を観察する方法です。 利用者本人に操作してもらう方法であり、専門家が経験則で点検する方法ではない。 【B(不正解)】 ? 大量のアクセスを与えて性能や安定性を確かめるテストです。 応答速度などの性能を見るテストで、画面の使いやすさの点検ではない。 【C(正解)】 ? 専門家が経験則(ヒューリスティクス)を基準に画面を評価する方法です。 利用者を集めずに、専門家が経験則に照らして問題を見つける手法である。今回の説明に合う。 【D(不正解)】 ? 利用者に質問票で感想や満足度を答えてもらう方法です。 利用者の主観的な評価を集める方法で、専門家による点検ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. 家計簿アプリの改善で、開発側は機能追加の案を多く持つが、利用者の困りごとはまだ調べていない。人間中心設計に沿った次の一手は?

    A. 案に挙がった機能を全部作り、公開してから反応を見る B. 社内の開発者だけで画面を見直し、仕様を確定する C. 競合アプリより機能の数が多くなるように計画する D. 利用者の使い方と状況を調べて要求をまとめ、試作を利用者に評価してもらう

    答えと解説

    正解: D 【A(不正解)】 ? 作ってから反応を確かめる進め方です。 利用状況や要求を確かめないまま作るため、利用者の困りごとに合わない機能が増えるおそれがある。 【B(不正解)】 ? 作り手の視点だけで決める進め方です。 人間中心設計は利用者の参加と評価を重んじる。作り手だけで決める進め方とは逆である。 【C(不正解)】 ? 機能の数を比べて決める進め方です。 機能の多さは使いやすさを保証しない。利用者の状況を調べる手順が抜けている。 【D(正解)】 ? 利用の状況を理解し、試作の評価を繰り返す進め方です。 利用状況の理解、要求の明確化、設計、利用者による評価を繰り返すのが人間中心設計の流れである。

    出典: ISO 9241-210:2019 Human-centred design for interactive systems/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  6. 音声を標本化周波数 8 kHz、量子化ビット数 16 ビットの PCM でモノラル録音した。圧縮しない場合、1 分間のデータ量は何バイトか。

    A. 960,000 バイト B. 480,000 バイト C. 7,680,000 バイト D. 16,000 バイト

    答えと解説

    正解: A 【A(正解)】 ? 1 秒あたりのビット数に秒数を掛け、8 で割った値です。 8,000 回/秒 × 16 ビット × 60 秒 = 7,680,000 ビット。8 で割ると 960,000 バイトになる。 【B(不正解)】 ? 量子化ビット数を 8 ビットとして計算した値です。 8,000 × 8 × 60 ÷ 8 = 480,000 になる。量子化ビット数 16 ビットを使っていない。 【C(不正解)】 ? 1 分間のビット数をそのままバイトとして扱った値です。 7,680,000 はビット数である。1 バイトは 8 ビットなので 8 で割る必要がある。 【D(不正解)】 ? 1 秒間のデータ量だけを計算した値です。 8,000 × 16 ÷ 8 = 16,000 バイトは 1 秒分である。60 秒分を求めていない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  7. 会社のロゴを、名刺の小さな印刷から看板の大きな印刷まで、拡大しても輪郭がギザギザにならないように管理したい。適したデータの形は?

    A. 画素を並べて表すラスターデータ B. 減色した GIF 形式 C. 座標と線や面の式で表すベクターデータ D. 高い圧縮率で保存した JPEG 形式

    答えと解説

    正解: C 【A(不正解)】 ? 画像を画素(ピクセル)の集まりで表す形式です。 拡大すると画素が目立ち、輪郭がギザギザに見えやすい。写真の表現には向く。 【B(不正解)】 ? 最大 256 色の画素データとして保存する形式です。 GIF も画素の集まりで表すため、大きく拡大すると輪郭が粗くなる。 【C(正解)】 ? 図形を点の座標と線・曲線・塗りの情報で表す形式です。 拡大・縮小しても計算で描き直すので、輪郭がなめらかなまま保てる。ロゴや図形に向く。 【D(不正解)】 ? 写真などを非可逆に圧縮して保存する形式です。 JPEG も画素データで、拡大すると粗くなる。圧縮で輪郭に乱れが出ることもある。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  8. 操作マニュアル用に、画面の文字や細い線を劣化させず、背景の透明部分も残した画像を保存したい。最も適切な形式は?

    A. JPEG B. PNG C. MP3 D. MPEG

    答えと解説

    正解: B 【A(不正解)】 ? 写真のような画像を、細部を少し捨てて小さく圧縮する形式です。 非可逆圧縮のため、文字の輪郭ににじみが出やすい。透明部分も持てない。 【B(正解)】 ? 元のデータを完全に復元できる圧縮で、透明度の情報も持てる形式です。 PNG は可逆圧縮で文字や線が劣化しない。アルファチャンネルで透明部分も表せる。 【C(不正解)】 ? 音声データを圧縮して保存する形式です。 音声の形式であり、画像の保存には使わない。 【D(不正解)】 ? 動画を圧縮して保存・配信するための規格です。 MPEG は動画の規格で、1 枚の静止画を保存する用途には合わない。

    出典: W3C Portable Network Graphics (PNG) Specification (Third Edition)/JPEG 公式サイト(JPEG 1 / ISO/IEC 10918)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

データベース方式

  1. データベースの 3 層スキーマのうち、利用者やアプリケーションから見たデータの定義を表すものはどれか。

    A. 概念スキーマ B. 内部スキーマ C. 外部スキーマ D. 関係スキーマ

    答えと解説

    正解: C 【A(不正解)】 ? 対象の世界全体の論理的なデータ構造を定義する層です。 表や列、関係など全体の論理構造を表す層である。個々の利用者の見え方ではない。 【B(不正解)】 ? 記憶装置上の格納方法など物理的な構造を定義する層です。 ファイルの配置や索引など物理的な構造を表す層である。 【C(正解)】 ? 利用者やプログラムごとに必要なデータの見え方を定義する層です。 ビューのように、利用者ごとに見せるデータを定義するのが外部スキーマである。 【D(不正解)】 ? 1 つの関係(表)の名前と属性の並びを表したものです。 1 つの表の構造を表す言葉で、3 層スキーマの層の名前ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. データベースを新しい記憶装置へ移し、格納形式も変えた。それでもアプリケーションを直さずに済んだ。この性質を支える考え方は?

    A. 格納方法の変更が上の層に及ばない物理的データ独立性 B. 同じデータを複数の場所に置いて持つデータの重複化 C. 表を分けて重複をなくす正規化 D. 更新を記録して障害に備えるロールフォワード

    答えと解説

    正解: A 【A(正解)】 ? 物理的な格納の変更から、論理的な構造を切り離す性質です。 3 層スキーマで内部スキーマを分けているので、格納方法を変えても上の層は変わらない。 【B(不正解)】 ? 同じデータを別の場所にもコピーして持つことです。 重複は可用性などに関わるが、格納形式の変更をアプリから隠す仕組みではない。 【C(不正解)】 ? データの重複や矛盾を減らすように表を分ける手順です。 正規化は論理設計の手順であり、記憶装置の変更をアプリから隠す仕組みではない。 【D(不正解)】 ? 記録した更新を再び反映して回復する方法です。 障害回復の方法であり、格納形式の変更とアプリの独立性とは関係しない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  3. SNS で「友人の友人」をたどって知り合い候補を出したい。人を点、つながりを線として持ち、関係をたどるのが得意なデータベースは?

    A. キーバリュー型データベース B. 列指向データベース C. 階層型データベース D. グラフデータベース

    答えと解説

    正解: D 【A(不正解)】 ? キーと値の組でデータを持ち、キーで素早く取り出す方式です。 キーで 1 件を取り出すのは得意だが、つながりを何段もたどる処理には向かない。 【B(不正解)】 ? 列ごとにデータをまとめて格納し、集計を速くする方式です。 大量データの列単位の集計に強いが、人と人の関係をたどる用途には向かない。 【C(不正解)】 ? 親子の木構造でデータを表す方式です。 1 つの子に親は 1 つという木構造で、網の目のような友人関係を表しにくい。 【D(正解)】 ? ノード(点)とエッジ(線)でデータとその関係を表す方式です。 AWS の解説も、ソーシャルネットワークや推薦をグラフ型の用途に挙げている。

    出典: AWS NoSQL データベースとは/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. 在庫データベースを 30 人が同時に更新しても、在庫数が食い違わないようにしたい。DBMS のどの機能が担うか。

    A. データ定義機能 B. 同時実行制御(排他制御) C. データ機密保護機能 D. 障害回復機能

    答えと解説

    正解: B 【A(不正解)】 ? 表や列などデータの構造を定義する機能です。 構造を決める機能であり、同時の更新で起きる食い違いは防がない。 【B(正解)】 ? 複数の処理が同じデータを同時に更新しないよう調整する機能です。 ロックなどで更新の順番を整え、データの一貫性を保つ。今回の目的に合う機能である。 【C(不正解)】 ? 利用者ごとにアクセスできるデータを制限する機能です。 見せる範囲を制限する機能で、同時の更新による食い違いは防げない。 【D(不正解)】 ? 障害が起きた後に、データを正しい状態へ戻す機能です。 障害後の復旧のための機能で、平常時の同時更新の調整とは役割が違う。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. 関係データベースの関係モデルで、ある属性が取りうる値の集合を何と呼ぶか。

    A. タプル B. 定義域(ドメイン) C. 実現値 D. 関係スキーマ

    答えと解説

    正解: B 【A(不正解)】 ? 表の 1 行(組)にあたるものです。 タプルは 1 件分のデータ(行)を指す。値の集合の名前ではない。 【B(正解)】 ? 属性が取りうる値の範囲や集合のことです。 例えば「月」なら 1〜12 の整数の集合が定義域になる。 【C(不正解)】 ? 表に実際に入っているデータの値のことです。 格納された具体的な値を指し、取りうる値の集合そのものではない。 【D(不正解)】 ? 表の名前と属性の並びで表した表の構造です。 表の構造の定義であり、1 つの属性の値の範囲ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  6. 通販サイトで買い物かごの中身を一時的に持ちたい。利用者 ID で 1 件をすぐに読み書きでき、複雑な検索は不要である。最も適した方式は?

    A. キーバリュー型データベース B. データウェアハウス C. グラフデータベース D. 階層型データベース

    答えと解説

    正解: A 【A(正解)】 ? 一意なキーと値の組でデータを持つ方式です。 利用者 ID をキーに中身を素早く読み書きできる。AWS の解説も、主キーだけで読むセッション情報の管理を用途に挙げている。 【B(不正解)】 ? 分析のために過去のデータを統合して蓄積する仕組みです。 長期の分析向けで、買い物中の一時的なデータを素早く読み書きする用途には向かない。 【C(不正解)】 ? 点と線でデータの関係を表す方式です。 関係をたどる処理が得意で、ID で 1 件を出し入れするだけの用途には大げさである。 【D(不正解)】 ? 親子の木構造でデータを持つ方式です。 決まった親子関係の表現に向くが、キーで単純に出し入れする用途に特に強いわけではない。

    出典: AWS「キーバリューデータベースとは」/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

データベース設計と正規化

  1. E-R 図で「1 人の顧客は複数の注文をする。1 件の注文は 1 人の顧客が行う」を表すとき、顧客と注文の関係(カーディナリティ)は?

    A. 1 対 1 B. 1 対多 C. 多対多 D. 0 対 0

    答えと解説

    正解: B 【A(不正解)】 ? 片方の 1 件が、もう片方のちょうど 1 件と対応する関係です。 1 人の顧客が複数の注文をするので、1 対 1 にはならない。 【B(正解)】 ? 片方の 1 件が、もう片方の複数件と対応する関係です。 顧客 1 人に注文が複数、注文 1 件に顧客は 1 人なので 1 対多になる。 【C(不正解)】 ? どちらの側から見ても、相手の複数件と対応する関係です。 注文 1 件に対応する顧客は 1 人だけなので、多対多ではない。 【D(不正解)】 ? どちらも相手を持たない状態を表す言い方です。 カーディナリティの表し方として一般的なものではなく、今回の関係とも合わない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. 「学生は複数の講義を履修し、講義には複数の学生がいる」関係を関係データベースで表したい。最も適切な表の設計は?

    A. 「履修」表を作り、学生番号と講義番号を持たせる B. 学生表に「講義番号 1」「講義番号 2」…の列を並べる C. 講義表の 1 つの列に、履修する学生番号をカンマ区切りで入れる D. 学生表と講義表を 1 つの表にまとめ、全項目を横に並べる

    答えと解説

    正解: A 【A(正解)】 ? 2 つの表の間に、組合せを記録する表を置く設計です。 多対多は、両方の主キーを外部キーとして持つ連関の表で 1 対多 2 つに分けて表す。 【B(不正解)】 ? 1 行の中に同じ種類の項目を繰り返し持たせる設計です。 繰返し項目になり、講義数が増えると列が足りなくなる。正規化の考え方に反する。 【C(不正解)】 ? 1 つの欄に複数の値をまとめて入れる設計です。 1 つの欄に複数の値が入り、第 1 正規形を満たさない。検索や更新も難しくなる。 【D(不正解)】 ? すべての項目を 1 つの大きな表に入れる設計です。 同じ学生や講義の情報が何度も重複し、更新時に矛盾が起きやすくなる。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2/PostgreSQL 文書 Constraints

    この問題へのリンク
  3. 顧客表の「電話番号」列に、自宅と携帯の番号を「03-…, 090-…」とカンマ区切りで入れていた。正規化の観点での問題と対応は?

    A. 主キーが無いので、電話番号の列を主キーにする B. 推移関数従属があるので、第 3 正規形にする C. 列の値が長いので、列に入る文字数の上限を増やす D. 1 つの欄に値が複数あるので、別表の行に分ける

    答えと解説

    正解: D 【A(不正解)】 ? 電話番号で行を一意に決める対応です。 1 つの欄に複数の値が入ることが問題であり、主キーを変えても解決しない。 【B(不正解)】 ? 主キー以外の項目を介した従属をなくす対応です。 今回の問題は 1 つの欄の中の繰返しである。推移関数従属の話ではない。 【C(不正解)】 ? 格納できる文字数を広げる対応です。 長さを増やしても、1 つの欄に複数の値が入る問題はそのまま残る。 【D(正解)】 ? 繰返しの値を、1 行に 1 つずつ持つよう分ける対応です。 各欄に値が 1 つだけの状態が第 1 正規形である。電話番号を別表の行に分けて解消する。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. 受注明細表(受注番号, 商品番号, 商品名, 数量)の主キーは {受注番号, 商品番号} である。商品名は商品番号だけで決まる。次に行う正規化は?

    A. 数量を別の表に分けて第 3 正規形にする B. 受注番号だけを主キーにして第 1 正規形にする C. 商品番号と商品名を商品表に分け、第 2 正規形にする D. 受注明細表と商品表を 1 つにまとめる

    答えと解説

    正解: C 【A(不正解)】 ? 数量を独立した表として切り出す対応です。 数量は受注番号と商品番号の両方で決まり、主キー全体に従属している。分ける理由がない。 【B(不正解)】 ? 主キーを 1 つの項目に減らす対応です。 受注番号だけでは明細の行を一意に決められない。正規化の手順でもない。 【C(正解)】 ? 主キーの一部だけで決まる項目を別の表に移す対応です。 商品名は主キーの一部(商品番号)に従属する部分関数従属である。分ければ第 2 正規形になる。 【D(不正解)】 ? 表を結合して 1 つにする対応です。 まとめると商品名の重複が増え、部分関数従属もそのまま残る。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. 社員表(社員番号, 氏名, 部署コード, 部署名)の主キーは社員番号で、部署名は部署コードで決まる。部署名を変えるたびに多くの行の更新が要る。原因は?

    A. 部分関数従属が残っている B. 推移関数従属が残っている C. 繰返し項目が残っている D. 外部キーが設定されている

    答えと解説

    正解: B 【A(不正解)】 ? 主キーの一部だけで決まる項目があることです。 主キーは社員番号 1 つだけなので、主キーの一部に従属するという状態は起きない。 【B(正解)】 ? 主キーで決まる項目を介して、さらに別の項目が決まることです。 社員番号→部署コード→部署名の推移関数従属がある。部署表に分ければ第 3 正規形になる。 【C(不正解)】 ? 1 行の中に同じ種類の値が複数あることです。 各欄の値は 1 つずつなので、第 1 正規形の問題はない。 【D(不正解)】 ? 他の表の主キーを参照する列があることです。 外部キーは参照の整合性を守る仕組みで、重複した更新の原因ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  6. 1 件 200 バイトのレコードを 50,000 件格納する。1 ブロックは 4,000 バイトで、レコードはブロックをまたがない。必要なブロック数は?

    A. 2,000 ブロック B. 10,000 ブロック C. 250 ブロック D. 2,500 ブロック

    答えと解説

    正解: D 【A(不正解)】 ? 1 ブロックに 25 件入るとして計算した値です。 1 ブロックに入るのは 4,000 ÷ 200 = 20 件である。25 件ではない。 【B(不正解)】 ? 1 ブロックに 5 件入るとして計算した値です。 1 ブロックに 20 件入るので、ブロック数はもっと少なくなる。 【C(不正解)】 ? 1 ブロックに 200 件入るとして計算した値です。 ブロックの大きさとレコードの大きさを取り違えている。1 ブロックには 20 件しか入らない。 【D(正解)】 ? 1 ブロックあたりの件数で全件数を割った値です。 4,000 ÷ 200 = 20 件/ブロック。50,000 ÷ 20 = 2,500 ブロックになる。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

データ操作と SQL

  1. 社員表から「氏名」と「部署」の 2 列だけを取り出す関係演算はどれか。

    A. 選択 B. 結合 C. 射影 D. 直積

    答えと解説

    正解: C 【A(不正解)】 ? 条件に合う行を取り出す演算です。 行を絞り込む演算であり、列を取り出す演算ではない。 【B(不正解)】 ? 共通の列を手がかりに 2 つの表をつなぐ演算です。 表を組み合わせる演算で、1 つの表から列を選ぶ演算ではない。 【C(正解)】 ? 表から指定した列だけを取り出す演算です。 氏名と部署の列だけを取り出すのは射影である。SQL では SELECT 句で列を指定する。 【D(不正解)】 ? 2 つの表の行をすべて組み合わせる演算です。 行の全組合せを作る演算で、列を選ぶ演算ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. 社員表から、平均給与が 50 万円以上の部署だけを一覧にしたい。最も適切な SQL は?

    A. SELECT 部署 FROM 社員 WHERE AVG(給与) >= 500000 GROUP BY 部署 B. SELECT 部署 FROM 社員 GROUP BY 部署 HAVING AVG(給与) >= 500000 C. SELECT 部署 FROM 社員 WHERE 給与 >= 500000 GROUP BY 部署 D. SELECT 部署 FROM 社員 ORDER BY AVG(給与) DESC

    答えと解説

    正解: B 【A(不正解)】 ? WHERE 句に集約関数を書いた SQL です。 WHERE は集計の前に行を選ぶ句で、集約関数は書けない。エラーになる。 【B(正解)】 ? グループ化した後の集計結果に条件を付けた SQL です。 HAVING は集計した後のグループを選ぶ。部署ごとの平均で絞り込むにはこの形を使う。 【C(不正解)】 ? 給与が 50 万円以上の社員がいる部署を出す SQL です。 個々の社員の給与で絞っているので、部署の平均給与の条件にはならない。 【D(不正解)】 ? 部署の平均給与の高い順に並べようとする SQL です。 GROUP BY が無く、条件で絞り込んでもいない。求める一覧にならない。

    出典: PostgreSQL 文書 Aggregate Functions/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  3. 「今年度会員」表と「昨年度会員」表は同じ列の構成である。両方の年度に会員だった人だけを出したい。使う集合演算は?

    A. UNION B. EXCEPT C. CROSS JOIN D. INTERSECT

    答えと解説

    正解: D 【A(不正解)】 ? 2 つの問合せ結果を合わせ、重複を除いて返す演算です。 どちらか一方にいる人も含めた和になる。両方にいる人だけには絞れない。 【B(不正解)】 ? 1 つ目の結果から 2 つ目の結果にある行を除く演算です。 差を求める演算で、今年度だけの会員などを出すのに使う。 【C(不正解)】 ? 2 つの表の行をすべて組み合わせる結合です。 直積を作る結合で、共通する行を取り出す演算ではない。 【D(正解)】 ? 2 つの問合せ結果の両方にある行だけを返す演算です。 両方の年度にいる人は 2 つの結果の積(共通部分)である。INTERSECT を使う。

    出典: PostgreSQL 文書 Combining Queries (UNION, INTERSECT, EXCEPT)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. 分析担当のアカウントに、売上表のデータを見ることだけを許可したい。最も適切な SQL は?

    A. GRANT SELECT ON 売上 TO 分析担当 B. GRANT ALL PRIVILEGES ON 売上 TO 分析担当 C. GRANT UPDATE ON 売上 TO 分析担当 D. REVOKE SELECT ON 売上 FROM 分析担当

    答えと解説

    正解: A 【A(正解)】 ? 売上表を検索する権限を付与する文です。 SELECT 権限だけを与えれば参照はできるが、更新や削除はできない。 【B(不正解)】 ? 売上表に対するすべての権限を付与する文です。 更新や削除の権限まで与えてしまい、見るだけという条件を超える。 【C(不正解)】 ? 売上表を更新する権限を付与する文です。 更新の権限であり、見るだけの利用には合わない。必要以上の権限になる。 【D(不正解)】 ? 売上表を検索する権限を取り消す文です。 権限を取り消す文なので、データを見られなくなる。

    出典: PostgreSQL 文書 GRANT/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. 注文表の「顧客番号」に、顧客表に存在しない番号が登録される不具合が起きた。データベース側で防ぐのに最も適切な制約は?

    A. 検査制約(CHECK) B. 一意性制約(UNIQUE) C. 参照制約(外部キー) D. 非 NULL 制約(NOT NULL)

    答えと解説

    正解: C 【A(不正解)】 ? 列の値が式で決めた条件を満たすかを確かめる制約です。 同じ行の値の条件は確かめられるが、他の表に存在するかは調べられない。 【B(不正解)】 ? 列の値が表の中で重複しないことを求める制約です。 重複を防ぐ制約で、顧客表に存在するかどうかは確かめない。 【C(正解)】 ? 他の表の主キーなどに存在する値だけを許す制約です。 顧客番号を外部キーにすれば、顧客表に無い番号の登録を DBMS が拒否する。 【D(不正解)】 ? 列に空値(NULL)が入らないようにする制約です。 空でないことは保証するが、存在しない番号が入るのは防げない。

    出典: PostgreSQL 文書 Constraints/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  6. 次のビューのうち、一般にビューを通して元の表の行を更新できるものはどれか。

    A. 部署ごとの人数を GROUP BY で集計したビュー B. DISTINCT で重複を除いた部署名のビュー C. 社員表から WHERE で営業部の行だけを選んだビュー D. 2 つの表を UNION で合わせたビュー

    答えと解説

    正解: C 【A(不正解)】 ? グループ化して集計した結果を見せるビューです。 集計結果の 1 行は元の表の 1 行と対応しないため、ビューを通した更新はできない。 【B(不正解)】 ? 重複を除いた値の一覧を見せるビューです。 重複を除くと元の行との対応が失われるため、更新できない。 【C(正解)】 ? 1 つの表から条件で行を絞っただけのビューです。 元の 1 行とビューの 1 行が対応するので、ビューを通して更新できる。 【D(不正解)】 ? 2 つの問合せ結果を合わせて見せるビューです。 集合演算を含むと、更新をどちらの表に反映するか決まらない。

    出典: PostgreSQL 文書 CREATE VIEW(Updatable Views)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  7. 商品表から、価格が全商品の平均価格より高い商品を出したい。最も適切な SQL は?

    A. SELECT 商品名 FROM 商品 WHERE 価格 > AVG(価格) B. SELECT 商品名 FROM 商品 GROUP BY 商品名 HAVING 価格 > AVG(価格) C. SELECT 商品名 FROM 商品 ORDER BY 価格 DESC D. SELECT 商品名 FROM 商品 WHERE 価格 > (SELECT AVG(価格) FROM 商品)

    答えと解説

    正解: D 【A(不正解)】 ? WHERE 句で直接平均と比べる SQL です。 WHERE 句には集約関数を書けないため、エラーになる。 【B(不正解)】 ? 商品名ごとにグループ化して比べる SQL です。 価格はグループ化の列でないため、一般にエラーになる。仮に動いても商品名ごとの平均と比べることになり、全商品の平均とは比べていない。 【C(不正解)】 ? 価格の高い順に並べるだけの SQL です。 並べ替えるだけで、平均より高いという条件で絞り込んでいない。 【D(正解)】 ? 副問合せで先に平均を求めて比べる SQL です。 副問合せが全商品の平均を 1 つの値で返し、それと各行の価格を比べられる。

    出典: PostgreSQL 文書 Aggregate Functions/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

トランザクション処理

  1. 口座振替の処理で、出金だけが反映されて入金が反映されない状態は許されない。この要求にあたる ACID 特性の性質は?

    A. 原子性(Atomicity) B. 一貫性(Consistency) C. 独立性(Isolation) D. 耐久性(Durability)

    答えと解説

    正解: A 【A(正解)】 ? トランザクションの処理が、全部行われるか全く行われないかのどちらかになる性質です。 出金と入金をひとまとまりとし、途中で失敗したら全部取り消す。この要求は原子性である。 【B(不正解)】 ? データが決められた制約を満たす正しい状態に保たれる性質です。 整合した状態を保つ性質だが、全部か無しかの扱いを直接表すのは別の性質である。 【C(不正解)】 ? 同時に動く複数の処理が互いに影響し合わない性質です。 同時実行の干渉を防ぐ性質で、1 つの処理の途中で止まる問題とは別である。 【D(不正解)】 ? 確定した結果が障害後も失われない性質です。 コミット後の結果を守る性質で、途中までの反映を防ぐことではない。

    出典: PostgreSQL 文書 Transactions/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. トランザクション T1 があるデータに共有ロックをかけている。別のトランザクション T2 が同じデータに対してすぐに獲得できるロックは?

    A. 専有ロックだけ B. 共有ロックだけ C. 共有ロックと専有ロックの両方 D. どちらのロックも獲得できない

    答えと解説

    正解: B 【A(不正解)】 ? T2 がデータを書き換えるためのロックだけを指します。 共有ロックがかかったデータに専有ロックをかけるには、T1 の解放を待つ必要がある。 【B(正解)】 ? T2 もデータを読むためのロックだけを指します。 共有ロックどうしは両立するので、読取りは同時にできる。専有ロックは待たされる。 【C(不正解)】 ? 読むためのロックと書き換えるためのロックの両方を指します。 専有ロックは共有ロックと両立しない。両方ともすぐ獲得できるわけではない。 【D(不正解)】 ? T1 が解放するまで何もできない状態を指します。 共有ロックどうしは両立するため、読取りのロックは獲得できる。

    出典: PostgreSQL 文書 Explicit Locking(Deadlocks)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  3. 処理 X は口座 A→B の順に、処理 Y は口座 B→A の順にロックして更新する。同時に動くと互いに待ち続けた。再発を防ぐ設計は?

    A. ロックを待つ時間をなくすため、ロックを使わずに更新する B. 処理 Y の実行回数を減らす C. ロックの単位を表全体から列単位に細かくする D. どの処理も口座番号の小さい順など、同じ順序でロックする

    答えと解説

    正解: D 【A(不正解)】 ? 排他制御をやめて同時に更新できるようにする設計です。 ロックをやめると同時の更新で残高が食い違う。排他制御そのものは必要である。 【B(不正解)】 ? 同時に動く機会を減らす設計です。 回数を減らしても同時に動けば同じ状態は起きる。根本の対策にならない。 【C(不正解)】 ? ロックの範囲を変える設計です。 ロック粒度を変えても、取る順序が逆ならデッドロックは起きうる。 【D(正解)】 ? ロックを獲得する順序をそろえる設計です。 全処理が同じ順序でロックを取れば、互いに相手を待つ輪ができず、デッドロックが起きない。

    出典: PostgreSQL 文書 Explicit Locking(Deadlocks)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. データベースを置いたディスクが壊れた。前夜のフルバックアップと、その後の更新を記録したジャーナルファイルは別の装置にある。最も適切な回復手順は?

    A. 前夜のバックアップを戻し、更新後の記録を使ってロールフォワードする B. 壊れたディスクのまま、更新前の記録でロールバックする C. 前夜のバックアップを戻すだけで運用を再開する D. 空のデータベースを作り直し、利用者に再入力を頼む

    答えと解説

    正解: A 【A(正解)】 ? バックアップから戻した後、記録した更新を順に再反映する手順です。 媒体障害ではバックアップを戻し、更新後ログで障害直前までロールフォワードする。 【B(不正解)】 ? 未確定の更新を取り消す手順です。 ディスクが壊れているとデータ自体が無い。ロールバックだけでは回復できない。 【C(不正解)】 ? バックアップ時点の状態で再開する手順です。 バックアップ後に確定した更新が失われる。障害直前の状態まで戻せていない。 【D(不正解)】 ? データを作り直して最初から入れ直す手順です。 バックアップとログがあるのに使わず、手間と入力ミスの危険が大きい。

    出典: PostgreSQL 文書 Continuous Archiving and Point-in-Time Recovery/PostgreSQL 文書 Write-Ahead Logging (WAL)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. 停電でデータベースが止まった。再起動後、停電の時点でまだコミットしていなかったトランザクションの更新はどう扱うか。

    A. 更新後の記録でロールフォワードし、結果を確定させる B. 更新前の記録を使ってロールバックし、処理前の状態に戻す C. そのまま残し、次に同じ処理が動いたときに上書きさせる D. チェックポイントの時点のデータをすべて捨てる

    答えと解説

    正解: B 【A(不正解)】 ? 記録した更新を再反映して確定させる扱いです。 コミットしていない処理を確定させると、利用者が確定していない更新が残ってしまう。 【B(正解)】 ? 未確定の更新を取り消し、処理前の値に戻す扱いです。 未コミットの処理は無かったことにする。更新前の記録でロールバックして原子性を守る。 【C(不正解)】 ? 途中の状態を放置する扱いです。 中途半端な更新が残り、データの整合性が崩れる。 【D(不正解)】 ? 定期的に書き出した時点より前のデータを捨てる扱いです。 チェックポイントは回復の起点に使う時点であり、データを捨てるためのものではない。

    出典: Oracle Database 19c 概要(インスタンス・リカバリ)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  6. 受注表で「受注日が 4 月 1 日から 4 月 30 日まで」の行を受注日順に取り出す処理が遅い。受注日の列に付けるインデックスとして向くものは?

    A. ハッシュインデックス B. ビットマップインデックス C. B-tree インデックス D. 転置インデックス

    答えと解説

    正解: C 【A(不正解)】 ? 値から計算したハッシュ値で位置を探す索引です。 等しい値の検索だけが得意で、範囲の検索や並べ替えには使いにくい。 【B(不正解)】 ? 値の種類ごとに行の有無をビットで表す索引です。 値の種類が少ない列(性別など)や、更新の少ない分析用の表に向く。日付の範囲検索の第一候補ではない。 【C(正解)】 ? 値を順序よく木構造に並べて持つ索引です。 大小比較や BETWEEN、並べ替えに使える。日付の範囲検索に向く。 【D(不正解)】 ? 文書中の語から、その語を含む文書を引けるようにした索引です。 全文検索などに使う索引で、日付の範囲検索に使うものではない。

    出典: PostgreSQL 文書 Index Types/Oracle Database 19c 概要(索引と索引構成表・ビットマップ索引)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

データベース応用

  1. センサーのログ、画像、業務システムのデータなどを、形式をそろえずに元のまま大量に蓄えておく仕組みは?

    A. データマート B. データレイク C. データウェアハウス D. OLTP

    答えと解説

    正解: B 【A(不正解)】 ? 特定の部門や目的のために切り出した分析用データです。 目的に合わせて整えた小さな分析用のデータで、生データを広く貯める仕組みではない。 【B(正解)】 ? 構造化データも非構造化データも元の形のまま蓄える仕組みです。 AWS の解説も、取り込む時点で構造(スキーマ)を決めずに保存できる点を挙げている。 【C(不正解)】 ? 分析のために整えたデータを、決めた構造で蓄える仕組みです。 あらかじめ構造を決め、整えたデータを蓄える。形式をそろえない保存とは違う。 【D(不正解)】 ? 受注や入金など日々の取引を処理するシステムです。 取引を素早く処理する仕組みで、多様な生データを貯めておく仕組みではない。

    出典: AWS データレイクとは/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. 売上分析で、年単位の集計から月単位、さらに日単位へと細かく見ていく OLAP の操作は?

    A. ロールアップ B. スライス C. ドリルダウン D. データクレンジング

    答えと解説

    正解: C 【A(不正解)】 ? 細かいデータをまとめて、より大きな単位で見る操作です。 日から月、月から年へとまとめる向きの操作で、今回とは逆である。 【B(不正解)】 ? 多次元のデータから、ある次元の値を固定して断面を切り出す操作です。 例えば特定の月だけの表を切り出す操作で、細かくたどる操作ではない。 【C(正解)】 ? 集計の単位を細かくして、詳しいデータへ掘り下げる操作です。 年から月、月から日へと詳しく見ていくのはドリルダウンである。 【D(不正解)】 ? 入力ミスや表記のゆれを直してデータを整える作業です。 分析の前処理であり、集計の細かさを変える操作ではない。

    出典: AWS OLAP とは/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  3. クラウドの分析基盤で、取り出したデータをまず変換せずに蓄え、その後に基盤の処理能力を使って変換したい。この進め方は?

    A. ETL B. OLTP C. レプリケーション D. ELT

    答えと解説

    正解: D 【A(不正解)】 ? 抽出→変換→書き込みの順でデータを移す方式です。 ETL は書き込む前に変換する。先に蓄えて後で変換する今回の順序とは違う。 【B(不正解)】 ? 日々の取引を素早く処理する方式です。 取引の処理方式であり、分析用にデータを移す手順の名前ではない。 【C(不正解)】 ? 同じデータの複製を別の場所に作って同期する仕組みです。 複製を作る仕組みで、変換の順序を表す言葉ではない。 【D(正解)】 ? 抽出→書き込み→変換の順でデータを移す方式です。 先に蓄えて、蓄えた先の基盤で変換する。AWS の解説もこの順序を ELT と説明している。

    出典: AWS ETL とは/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. 本社 DB の在庫と支店 DB の売上を 1 つのトランザクションで更新する。片方だけ反映されるのを防ぐため、全サイトの準備を確かめてから確定させる仕組みは?

    A. 2 相コミットメント B. レプリケーション C. ロールフォワード D. ビュー

    答えと解説

    正解: A 【A(正解)】 ? 全参加者に確定できるかを問い合わせ、全員が可なら確定する方式です。 第 1 相で全サイトが準備でき、第 2 相で一斉にコミットする。片方だけの反映を防げる。 【B(不正解)】 ? あるサイトのデータの複製を別のサイトに作る仕組みです。 複製の同期の仕組みで、別々のデータを 1 つの処理として確定させる仕組みではない。 【C(不正解)】 ? 障害後に記録した更新を再び反映する方法です。 障害回復の方法であり、複数サイトの確定をそろえる手順ではない。 【D(不正解)】 ? 表から必要なデータを見せるための仮想の表です。 データの見せ方を定義するもので、複数サイトの更新を確定させる仕組みではない。

    出典: PostgreSQL 文書 PREPARE TRANSACTION/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. データ項目の名前・意味・型・格納場所などのメタデータを集めて一元管理するものは?

    A. ジャーナルファイル B. データディクショナリ C. インデックス D. データマート

    答えと解説

    正解: B 【A(不正解)】 ? データベースの更新内容を記録するファイルです。 障害回復のための更新記録で、データ項目の意味を管理するものではない。 【B(正解)】 ? データ項目の定義や意味などの情報をまとめた辞書です。 データディクショナリはメタデータを集めて管理し、項目名の不統一を防ぐのに役立つ。 【C(不正解)】 ? 検索を速くするための索引です。 検索の性能のための仕組みで、データの意味を管理するものではない。 【D(不正解)】 ? 特定の目的のために切り出した分析用データです。 分析用のデータそのものであり、データの定義情報の管理ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

ネットワーク方式

  1. 次の IPv4 アドレスのうち、プライベート IP アドレスはどれか。

    A. 172.32.0.1 B. 11.0.0.1 C. 192.169.1.1 D. 192.168.10.5

    答えと解説

    正解: D 【A(不正解)】 ? 172 から始まるアドレスです。 プライベートの範囲は 172.16.0.0〜172.31.255.255 で、172.32 は範囲の外である。 【B(不正解)】 ? 11 から始まるアドレスです。 プライベートの範囲は 10.0.0.0〜10.255.255.255 で、11 から始まるアドレスは含まない。 【C(不正解)】 ? 192.169 から始まるアドレスです。 プライベートの範囲は 192.168.0.0〜192.168.255.255 で、192.169 は含まない。 【D(正解)】 ? 192.168 から始まるアドレスです。 RFC 1918 が定める 192.168.0.0〜192.168.255.255 の範囲に入る。

    出典: RFC 1918 Address Allocation for Private Internets/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. 伝送速度 100 M ビット/秒、回線利用率 60 % の回線で、300 M バイトのファイルを送る。転送時間は何秒か。

    A. 24 秒 B. 5 秒 C. 40 秒 D. 3 秒

    答えと解説

    正解: C 【A(不正解)】 ? ビットに直した後、回線利用率を考えずに計算した値です。 2,400 M ビット ÷ 100 M ビット/秒 = 24 秒。実際に使える速度は 60 % なので足りない。 【B(不正解)】 ? バイトをビットに直さずに計算した値です。 300 ÷ 60 = 5 になる。1 バイトは 8 ビットなので、ビットに直す必要がある。 【C(正解)】 ? データ量をビットに直し、実際に使える速度で割った値です。 300 M バイト × 8 = 2,400 M ビット。100 × 0.6 = 60 M ビット/秒で割ると 40 秒になる。 【D(不正解)】 ? バイトのままで、伝送速度 100 で割った値です。 300 ÷ 100 = 3 になる。ビットへの換算と回線利用率の両方が抜けている。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  3. 社内の 50 台の PC が、ルータの 1 つのグローバル IP アドレスを共有して同時にインターネットへ接続している。これを可能にする技術は?

    A. NAPT B. DNS C. DHCP D. VLAN

    答えと解説

    正解: A 【A(正解)】 ? IP アドレスに加えてポート番号も変換する技術です。 ポート番号で通信を区別するので、1 つのグローバルアドレスを多数の端末で共有できる。 【B(不正解)】 ? ドメイン名と IP アドレスを対応づける仕組みです。 名前解決の仕組みで、アドレスを共有して同時に通信させるものではない。 【C(不正解)】 ? 端末に IP アドレスなどの設定を自動で配る仕組みです。 社内の端末にアドレスを配るが、1 つのグローバルアドレスを共有させる仕組みではない。 【D(不正解)】 ? 1 つのスイッチの中で論理的に LAN を分ける技術です。 LAN を分ける技術で、外部への通信でアドレスを変換するものではない。

    出典: RFC 3022 Traditional IP Network Address Translator (Traditional NAT)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. データを小さな単位に分けて送り、1 本の回線を多くの通信で共有して効率よく使う交換方式は?

    A. 回線交換 B. パケット交換 C. 専用線 D. 全二重通信

    答えと解説

    正解: B 【A(不正解)】 ? 通信の間、相手との経路を専有して確保する方式です。 回線交換は経路を占有するので、通信が無い間も回線が使われない。共有には向かない。 【B(正解)】 ? データを小さな単位に分けて送り、回線を共有する方式です。 パケット交換は分けたデータを回線上で混ぜて送るため、回線の利用効率が高い。 【C(不正解)】 ? 特定の 2 地点を常に結ぶ回線サービスです。 2 地点間で専有して使う回線で、多くの通信で共有する方式ではない。 【D(不正解)】 ? 送信と受信を同時に行える通信方式です。 同時に双方向へ送れるかを表す言葉で、交換方式の名前ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. コールセンターで、1 時間に 60 件の電話を受け、1 件の平均通話時間は 3 分である。この 1 時間の呼量は何アーランか。

    A. 1 アーラン B. 20 アーラン C. 180 アーラン D. 3 アーラン

    答えと解説

    正解: D 【A(不正解)】 ? 1 時間に回線が 1 本分使われ続けた量です。 合計の通話時間は 60 件 × 3 分 = 180 分で、60 分ではない。 【B(不正解)】 ? 件数を平均通話時間で割った値です。 60 ÷ 3 = 20 は意味のある量ではない。通話時間の合計を観測時間で割る。 【C(不正解)】 ? 通話時間の合計を分のまま答えた値です。 180 分を観測時間の 60 分で割る手順が抜けている。 【D(正解)】 ? 通話時間の合計を観測時間で割った値です。 60 件 × 3 分 = 180 分。180 分 ÷ 60 分 = 3 アーランで、平均 3 回線分使われている。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  6. 家庭の無線 LAN ルータに、古いゲーム機向けとして WEP を設定した SSID が残っていた。総務省の手引きに沿った対応は?

    A. ルータの電波の出力を上げて、通信を安定させる B. SSID の名前を自分の氏名に変えて、家族に分かりやすくする C. 不要ならその SSID を止め、必要なら WPA2 か WPA3 に変える D. WEP の暗号化キーを長く複雑にして、そのまま使い続ける

    答えと解説

    正解: C 【A(不正解)】 ? 電波の出力を上げる対応です。 電波が遠くまで届くと、第三者に見つかりやすくなる。古い方式の問題も残る。 【B(不正解)】 ? ネットワーク名を変える対応です。 総務省の手引きは、身元が分かる SSID 名にしないよう注意している。 【C(正解)】 ? 使わない設定を止め、新しい方式にそろえる対応です。 手引きは WEP など解読方法が知られた古い方式を避け、WPA2 か WPA3 を選ぶよう勧めている。 【D(不正解)】 ? 鍵の長さを伸ばして同じ方式を使う対応です。 WEP は方式そのものの解読方法が知られている。鍵を長くしても安全な方式にはならない。

    出典: 総務省 自宅 Wi-Fi 利用者向け簡易マニュアル(令和 7 年 2 月版)/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

データ通信と制御

  1. OSI 基本参照モデルで、異なるネットワークをまたいで宛先までの経路を選ぶ(ルーティング)役割を持つ層は?

    A. データリンク層 B. ネットワーク層 C. トランスポート層 D. プレゼンテーション層

    答えと解説

    正解: B 【A(不正解)】 ? 隣り合う機器の間でデータを確実に届ける層です。 同じネットワーク内の隣接する機器間の伝送を担う。経路の選択は行わない。 【B(正解)】 ? ネットワークをまたいで宛先までの経路を選び、中継する層です。 IP が働く層で、ルータがこの層で経路を選んでパケットを中継する。 【C(不正解)】 ? 端末の間で通信の信頼性や順序を管理する層です。 TCP や UDP が働く層で、経路の選択は下の層に任せる。 【D(不正解)】 ? 文字コードやデータの表現形式をそろえる層です。 データの表現を扱う層で、経路の選択とは関係しない。

    出典: ISO/IEC 7498-1:1994 OSI Basic Reference Model/IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  2. フロアの LAN で、受け取ったフレームの宛先 MAC アドレスを見て、宛先がつながるポートだけに転送したい。使う装置は?

    A. リピータ B. ルータ C. ゲートウェイ D. スイッチングハブ

    答えと解説

    正解: D 【A(不正解)】 ? 信号を増幅・整形して伝送距離を延ばす装置です。 物理層の装置で、宛先を見ずに信号をそのまま流す。 【B(不正解)】 ? IP アドレスを見てネットワーク間でパケットを中継する装置です。 ネットワーク層の装置で、MAC アドレスで LAN 内の転送先を選ぶ役割とは違う。 【C(不正解)】 ? プロトコルが異なるネットワークどうしを変換してつなぐ装置です。 上位の層で変換を行う装置で、LAN 内のフレーム転送に使うものではない。 【D(正解)】 ? MAC アドレスを学習し、宛先のポートだけにフレームを送る装置です。 データリンク層(レイヤー 2)で動き、宛先のポートだけに転送して無駄な通信を減らす。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  3. 送信と受信を同時に行えず、トランシーバのように交互に切り替えて通信する方式は?

    A. 単方向通信 B. 全二重通信 C. 半二重通信 D. 波長分割多重

    答えと解説

    正解: C 【A(不正解)】 ? 一方からもう一方へ、決まった向きだけに送る方式です。 テレビ放送のように片方向だけで、返事を送ることができない。 【B(不正解)】 ? 送信と受信を同時に行える方式です。 電話のように同時に話せる方式で、交互に切り替える必要はない。 【C(正解)】 ? 双方向に送れるが、同時には送れず交互に切り替える方式です。 トランシーバのように、送る側と受ける側を切り替えながら双方向に通信する。 【D(不正解)】 ? 光ファイバで波長の違う複数の光を同時に送る方式です。 1 本の光ファイバで多くの信号を送る多重化の技術で、送受信の切替え方式ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  4. 無線 LAN で使われ、送信前に電波が空いているかを確かめ、さらにランダムな時間を待って衝突を避けるアクセス制御方式は?

    A. CSMA/CA B. CSMA/CD C. トークンパッシング D. ポーリング/セレクティング方式

    答えと解説

    正解: A 【A(正解)】 ? 送信前に待ち時間を設けて衝突そのものを避ける方式です。 無線では衝突を検知しにくいため、送る前に待って衝突を避けるこの方式を使う。 【B(不正解)】 ? 送信中に衝突を検知したら、待ってから送り直す方式です。 有線 LAN(バス型のイーサネット)で使われてきた方式で、衝突の検知を前提にしている。 【C(不正解)】 ? 送信権を表すトークンを持つ端末だけが送る方式です。 トークンを回して送信権を与える方式で、無線 LAN の標準的な方式ではない。 【D(不正解)】 ? 主局が従局に順に送信の有無を問い合わせる方式です。 主局が通信を制御する方式で、無線 LAN の衝突回避の方式ではない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  5. 各フロアの PC を中央の集線装置に 1 本ずつつなぐスター型の LAN を組んだ。この構成の特徴として最も適切なものは?

    A. 1 本のケーブルに全端末がつながり、両端に終端装置が要る B. 端末を環状につなぎ、データが一方向に回る C. 1 台の PC のケーブルが切れると、LAN 全体が止まる D. 中央の集線装置が故障すると、つながる全端末が通信できなくなる

    答えと解説

    正解: D 【A(不正解)】 ? 1 本の幹線に端末をぶら下げる構成の説明です。 これはバス型の特徴である。スター型は各端末が中央の装置に個別につながる。 【B(不正解)】 ? 端末を輪の形につなぐ構成の説明です。 これはリング型の特徴で、スター型の説明ではない。 【C(不正解)】 ? 1 か所の断線が全体に及ぶ構成の説明です。 スター型では各端末が個別につながるので、1 本の断線はその端末だけに影響する。 【D(正解)】 ? 中心の装置に通信が集まる構成の説明です。 スター型は端末の追加や切り離しが容易な一方、中央の装置が止まると全体に影響する。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク
  6. 社外からの Web アクセスを 1 台で受け付け、社内の複数の Web サーバへ振り分けたい。サーバの実体を外部から隠す効果も欲しい。置く装置は?

    A. 社内 PC が外部サイトを見るときに使うプロキシサーバ B. リバースプロキシサーバ C. リピータ D. スイッチングハブ

    答えと解説

    正解: B 【A(不正解)】 ? 内部の利用者に代わって外部へ接続するサーバです。 プロキシサーバは内部から外部への接続を代行する。外部からのアクセスを受ける今回とは向きが逆である。 【B(正解)】 ? 外部からの要求を受け、内部のサーバに代わって応答を中継するサーバです。 外部の利用者はリバースプロキシとだけ通信し、内部サーバへの振り分けと隠ぺいができる。 【C(不正解)】 ? 信号を増幅して伝送距離を延ばす装置です。 物理層の装置で、Web の要求を振り分ける働きはない。 【D(不正解)】 ? MAC アドレスで LAN 内の転送先を選ぶ装置です。 レイヤー 2 の装置で、Web の要求の中身を見て振り分ける働きはない。

    出典: IPA 基本情報技術者試験(レベル 2)シラバス Ver.9.2

    この問題へのリンク

通信プロトコル

  1. Web ブラウザが TCP でサーバとつながるとき、データを送る前に行う手順として適切なものは?

    A. 相手の MAC アドレスを調べ、確認なしでデータを送り始める B. DHCP サーバから IP アドレスを借り、それを接続の確立とみなす C. 送り手はデータを一度に送り、受け手は確認応答を返さない D. SYN、SYN と ACK、ACK の 3 回のやり取りで接続を確立する

    答えと解説

    正解: D 【A(不正解)】 ? LAN の中で相手の機器を特定する手順です。 MAC アドレスを調べるのは ARP の役割である。TCP は接続を確立してからデータを送る。 【B(不正解)】 ? 機器の設定を自動で受け取る手順です。 DHCP は IP アドレスなどの設定を配る仕組みで、TCP の接続確立とは別のものである。 【C(不正解)】 ? 確認応答を省いた送り方です。 TCP は確認応答と再送で確実に届ける。確認応答を返さない送り方は TCP の特徴に合わない。 【D(正解)】 ? スリーウェイハンドシェイクと呼ばれる手順です。 RFC 9293 は、接続の確立にスリーウェイハンドシェイクを使うと定めている。

    出典: RFC 9293 Transmission Control Protocol (TCP)

    この問題へのリンク
  2. 1 台のサーバで Web とメールを同時に提供している。届いたデータをどのアプリケーションに渡すかを区別するために使う情報は?

    A. MAC アドレス B. サブネットマスク C. ポート番号 D. TTL(生存時間)

    答えと解説

    正解: C 【A(不正解)】 ? LAN の中で機器を区別する番号です。 MAC アドレスは機器(ネットワークカード)を区別する番号で、同じサーバの中のアプリケーションは区別できない。 【B(不正解)】 ? IP アドレスのうちネットワーク部の長さを示す値です。 サブネットマスクはネットワークの範囲を表すもので、アプリケーションの区別には使わない。 【C(正解)】 ? トランスポート層で使う 16 ビットの番号です。 TCP と UDP はポート番号でアプリケーションのサービスを区別する。Web とメールは別のポート番号で待ち受ける。 【D(不正解)】 ? IP パケットが中継される回数の上限です。 TTL はパケットが経路上で回り続けないようにする値で、アプリケーションの区別には使わない。

    出典: RFC 9293 Transmission Control Protocol (TCP)/RFC 768 User Datagram Protocol

    この問題へのリンク
  3. 社内の IP 電話では、音声が少し欠けても遅れが少ないことを優先したい。音声データを運ぶトランスポート層のプロトコルとして向くものは?

    A. TCP B. UDP C. ICMP D. ARP

    答えと解説

    正解: B 【A(不正解)】 ? 接続を確立し、届かなかったデータを再送するプロトコルです。 再送や順序の制御で確実に届けるが、再送を待つ間に遅れが出る。遅れを嫌う音声には向きにくい。 【B(正解)】 ? 接続を確立せずにデータを送るプロトコルです。 RFC 768 は、UDP は配達や重複の防止を保証しないと書く。その分、手順が軽く遅れが少ない。 【C(不正解)】 ? 通信の問題を知らせる制御用のプロトコルです。 ICMP は IP の一部で、エラー通知や疎通確認に使う。音声データを運ぶためのものではない。 【D(不正解)】 ? IP アドレスから MAC アドレスを求めるプロトコルです。 ARP は相手の MAC アドレスを調べるもので、アプリケーションのデータは運ばない。

    出典: RFC 768 User Datagram Protocol/RFC 9293 Transmission Control Protocol (TCP)

    この問題へのリンク
  4. 同じ LAN にある相手へ IP パケットを送りたいが、相手の MAC アドレスがまだ分からない。このときに使われるプロトコルは?

    A. ARP B. DNS C. DHCP D. NTP

    答えと解説

    正解: A 【A(正解)】 ? IP アドレスとイーサネットのアドレスを対応付けるプロトコルです。 RFC 826 は、ARP が IP アドレスなどを 48 ビットのイーサネットアドレスに対応付けると定めている。問い合わせはブロードキャストで送る。 【B(不正解)】 ? 名前と IP アドレスを対応付ける仕組みです。 DNS はドメイン名から IP アドレスを調べる。IP アドレスから MAC アドレスは求めない。 【C(不正解)】 ? IP アドレスなどの設定を自動で配るプロトコルです。 DHCP は自分の IP アドレスを受け取る仕組みで、相手の MAC アドレスは調べない。 【D(不正解)】 ? 機器の時計を合わせるプロトコルです。 NTP は時刻の同期に使うもので、アドレスの対応付けとは関係がない。

    出典: RFC 826 An Ethernet Address Resolution Protocol

    この問題へのリンク
  5. 新しく LAN につないだ PC が、DHCP で IP アドレスを受け取ろうとしている。最初に PC が送るメッセージの説明として適切なものは?

    A. DHCPDISCOVER をブロードキャストし、DHCP サーバを探す B. DHCPACK を DHCP サーバに送り、割当てを確定させる C. DNS サーバに問い合わせて、自分の IP アドレスを調べる D. ARP 要求を送り、ルータに IP アドレスを割り当ててもらう

    答えと解説

    正解: A 【A(正解)】 ? まだアドレスを持たない機器が、ネットワーク全体へ呼びかけるメッセージです。 RFC 2131 では、クライアントがまず DHCPDISCOVER をブロードキャストし、サーバが DHCPOFFER で応じる。 【B(不正解)】 ? 割当ての確定を伝えるメッセージです。 DHCPACK はサーバが最後に送るメッセージである。クライアントが最初に送るものではない。 【C(不正解)】 ? 名前と IP アドレスを対応付ける問い合わせです。 DNS は名前解決の仕組みで、IP アドレスの割当てはしない。 【D(不正解)】 ? 相手の MAC アドレスを調べる問い合わせです。 ARP は MAC アドレスを調べるもので、IP アドレスは割り当てない。

    出典: RFC 2131 Dynamic Host Configuration Protocol

    この問題へのリンク
  6. 取引先へのメールを送るため、送信側のメールサーバが DNS に宛先ドメインのメールサーバを問い合わせる。このとき参照される資源レコードは?

    A. A レコード B. CNAME レコード C. PTR レコード D. MX レコード

    答えと解説

    正解: D 【A(不正解)】 ? 名前に対応するホストのアドレスを表すレコードです。 A レコードはホストの IPv4 アドレスを表す。メールの配送先サーバを示すのは別のレコードである。 【B(不正解)】 ? 別名に対する正式な名前を表すレコードです。 CNAME は別名と正式名の対応で、メールの配送先は示さない。 【C(不正解)】 ? アドレスから名前を引くときに使うレコードです。 PTR は逆引きに使う。メールの配送先を決めるときに見るものではない。 【D(正解)】 ? メールの交換(mail exchange)を担うサーバを表すレコードです。 RFC 1035 は MX を mail exchange と定める。RFC 5321 も、MX で次の配送先を決めると書く。

    出典: RFC 1035 Domain Names - Implementation and Specification/RFC 5321 Simple Mail Transfer Protocol

    この問題へのリンク
  7. 部署の LAN に 50 台の機器をつなぐ。192.168.10.0 を先頭に CIDR 表記でアドレスを割り当てるとき、足りるうちで最も小さいプレフィックスは? ネットワークアドレスとブロードキャストアドレスは機器に使わない。

    A. /25 B. /26 C. /27 D. /28

    答えと解説

    正解: B 【A(不正解)】 ? ホスト部が 7 ビットの範囲です。 ホスト部 7 ビットで 2^7−2=126 台まで使える。足りるが、/26 で足りるので最小ではない。 【B(正解)】 ? ホスト部が 6 ビットの範囲です。 ホスト部 6 ビットで 2^6−2=64−2=62 台まで使える。50 台が入り、これより小さい範囲では足りない。 【C(不正解)】 ? ホスト部が 5 ビットの範囲です。 ホスト部 5 ビットで 2^5−2=30 台までしか使えず、50 台に足りない。 【D(不正解)】 ? ホスト部が 4 ビットの範囲です。 ホスト部 4 ビットで 2^4−2=14 台までしか使えず、50 台に足りない。

    出典: RFC 4632 Classless Inter-domain Routing (CIDR)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  8. 動画配信サイトを HTTP/3 に対応させた。HTTP/2 と比べた HTTP/3 の特徴として適切なものは?

    A. TCP の上で動き、1 本の接続で 1 つの要求しか送れなくなる B. 暗号化をやめることで、通信の手順を短くしている C. UDP を使う QUIC の上で動き、1 つのストリームの損失が他を止めにくい D. メール配送と同じポート番号を使い、メールサーバで処理する

    答えと解説

    正解: C 【A(不正解)】 ? 通信の土台と同時に送れる数に関する説明です。 HTTP/3 は TCP ではなく QUIC の上で動く。複数のストリームを同時に扱える。 【B(不正解)】 ? 暗号化の有無に関する説明です。 RFC 9114 は、HTTP/3 が QUIC に組み込まれた TLS 1.3 で機密性と完全性を守ると書く。暗号化はやめていない。 【C(正解)】 ? 通信の土台とストリームの独立性に関する説明です。 RFC 9114 は、HTTP/3 を QUIC の上で動かし、詰まったストリームが他のストリームを妨げないと書く。HTTP/3 は UDP のポートで提供される。 【D(不正解)】 ? 待ち受けるポートと処理するサーバの説明です。 HTTP/3 は Web の通信であり、メール配送用のポートやメールサーバは使わない。

    出典: RFC 9114 HTTP/3

    この問題へのリンク

ネットワーク管理と応用

  1. 多数のルータの状態を 1 台の管理サーバで集めている。機器に異常が起きたとき、機器の側から管理サーバへすぐ知らせる SNMP の仕組みは?

    A. エージェントが送るトラップ(通知) B. 管理サーバが定期的に行う DHCP のリース更新 C. ルータが送る ARP のブロードキャスト D. メールサーバどうしの SMTP によるリレー

    答えと解説

    正解: A 【A(正解)】 ? 管理される機器が、問合せを待たずに送るメッセージです。 RFC 3411 は、通知を送る操作の分類(通知クラス)に Trap を挙げ、確認応答の無い操作としている。異常をすぐ知らせるのに使う。 【B(不正解)】 ? IP アドレスの貸出期間を延ばす手続です。 DHCP のリース更新はアドレス設定の仕組みで、機器の異常は知らせない。 【C(不正解)】 ? MAC アドレスを調べるための問合せです。 ARP はアドレスの対応付けに使うもので、異常の通知には使わない。 【D(不正解)】 ? メールをサーバからサーバへ転送する仕組みです。 SMTP はメールの配送に使う。ネットワーク機器の監視の仕組みではない。

    出典: RFC 3411 An Architecture for Describing SNMP Management Frameworks

    この問題へのリンク
  2. 本社から取引先のサーバへの ping は返るが、応答が遅い。経路上のどのルータで時間がかかっているかを確かめるのに向くコマンドは?

    A. netstat B. arp C. traceroute D. dig

    答えと解説

    正解: C 【A(不正解)】 ? 自分の機器の通信の接続状態を一覧するコマンドです。 netstat は自分の機器の接続やポートの状態を見るもので、経路上のルータは調べられない。 【B(不正解)】 ? IP アドレスと MAC アドレスの対応表を表示するコマンドです。 arp は同じ LAN の対応表を見るもので、遠くの経路は調べられない。 【C(正解)】 ? TTL を 1 から順に増やしてパケットを送るコマンドです。 TTL が尽きたルータは ICMP の時間超過を返す。RFC 1393 のとおり、その返答から経路上のルータを順に特定できる。 【D(不正解)】 ? DNS に問い合わせて結果を表示するコマンドです。 dig は名前解決を調べるもので、経路上の遅れは調べられない。

    出典: RFC 1393 Traceroute Using an IP Option/RFC 792 Internet Control Message Protocol/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  3. 社員が PC とスマートフォンの両方で同じメールを読み、フォルダ分けもそろえたい。メールをサーバに置いたまま扱える受信のプロトコルは?

    A. POP3 B. SMTP C. IMAP D. MIME

    答えと解説

    正解: C 【A(不正解)】 ? サーバのメールを端末に取り込むためのプロトコルです。 RFC 1939 は、POP3 はサーバ上での多くの操作を想定せず、取り込んだメールは通常サーバから消すと書く。 【B(不正解)】 ? メールの送信と転送に使うプロトコルです。 SMTP は送信と配送に使う。サーバ上のメールを読む受信のプロトコルではない。 【C(正解)】 ? Internet Message Access Protocol の略の受信プロトコルです。 RFC 9051 は、IMAP でサーバ上のメールボックス(フォルダ)を扱えると定める。複数の端末で同じ状態を見られる。 【D(不正解)】 ? メールで日本語や添付ファイルを扱うための規格です。 MIME はメールの中身の形式を決める規格で、受信のプロトコルではない。

    出典: RFC 9051 Internet Message Access Protocol (IMAP) - Version 4rev2/RFC 1939 Post Office Protocol - Version 3

    この問題へのリンク
  4. メールソフトから送ったメールは、送信側のメールサーバから宛先のメールサーバへ転送される。このサーバ間の転送に使われるプロトコルは?

    A. POP3 B. SMTP C. NTP D. FTP

    答えと解説

    正解: B 【A(不正解)】 ? サーバからメールを取り込む受信のプロトコルです。 POP3 は利用者がメールを受け取るときに使う。サーバ間の転送には使わない。 【B(正解)】 ? メールを確実に効率よく転送するためのプロトコルです。 RFC 5321 では、SMTP のサーバがリレーとしてメールを次のサーバへ転送する。IANA が定めたポートは 25 番である。 【C(不正解)】 ? 機器の時計を合わせるためのプロトコルです。 NTP は時刻の同期に使うもので、メールは運ばない。 【D(不正解)】 ? ファイルの転送に使うプロトコルです。 FTP はファイルのアップロードやダウンロードに使う。メールの配送には使わない。

    出典: RFC 5321 Simple Mail Transfer Protocol

    この問題へのリンク
  5. IoT 機器の増加で通信量が急に変わる。多数のネットワーク機器の経路設定を、機器ごとの手作業ではなくソフトウェアで集中して制御したい。この考え方は?

    A. VLAN B. SDN C. MIME D. NAT

    答えと解説

    正解: B 【A(不正解)】 ? 物理的な配線と関係なく LAN を論理的に分ける技術です。 VLAN は LAN を分ける技術で、ネットワーク全体をソフトウェアで集中制御する考え方ではない。 【B(正解)】 ? OpenFlow などの規格と組み合わせて使われる考え方です。 OpenFlow などを使い、ソフトウェアから機器の転送の動きを制御する。シラバスも仮想ネットワークの用語として挙げている。 【C(不正解)】 ? メールで画像や日本語を扱う規格です。 MIME はメールの中身の形式に関する規格で、経路の制御とは関係がない。 【D(不正解)】 ? プライベートとグローバルの IP アドレスを変換する技術です。 NAT はアドレスを変換する技術で、多数の機器の経路設定を集中制御するものではない。

    出典: 令和 3 年版 情報通信白書 レイヤー別にみる市場動向(総務省)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  6. 自社では無線局を開設・運用せず、携帯電話会社の通信サービスを利用して、自社ブランドの移動通信サービスを提供する事業者は?

    A. MNO(移動体通信事業者) B. ISP(インターネット接続事業者) C. CSIRT(インシデント対応チーム) D. MVNO(仮想移動体通信事業者)

    答えと解説

    正解: D 【A(不正解)】 ? 無線局を自ら開設・運用して移動通信サービスを提供する事業者です。 総務省の定義では、MNO はサービスに使う無線局を自ら開設・運用している。問題の事業者とは逆である。 【B(不正解)】 ? 利用者をインターネットにつなぐサービスを提供する事業者です。 ISP はインターネットへの接続を提供する事業者の呼び名で、無線局を持たない移動通信事業者を指す言葉ではない。 【C(不正解)】 ? 組織内でセキュリティ事故に対応するチームです。 CSIRT は情報セキュリティのインシデント対応の組織で、通信事業者の区分ではない。 【D(正解)】 ? MNO と対になる、移動通信事業者の区分の 1 つです。 総務省の定義では、MVNO は MNO のサービスを利用するか接続して提供し、無線局を自ら開設・運用しない。

    出典: 移動通信サービス等の区分の定義(総務省 資料)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク

情報セキュリティの目的と脅威・攻撃手法

  1. 情報セキュリティの対策として次の 4 つを検討している。主に完全性を高めるものは?

    A. Web サーバを 2 台にし、1 台が止まっても受注を続けられるようにする B. 顧客名簿を暗号化し、鍵を持つ担当者だけが読めるようにする C. 契約書の電子ファイルにハッシュ値を記録し、書き換えを検出できるようにする D. サーバ室に入退室管理を入れ、許可のない人を入れないようにする

    答えと解説

    正解: C 【A(不正解)】 ? 故障しても使い続けられるようにする対策です。 必要なときに使える状態を保つ対策で、主に可用性を高める。 【B(不正解)】 ? 見てよい人だけが見られるようにする対策です。 許可された人だけが情報を見られるようにする対策で、主に機密性を高める。 【C(正解)】 ? 情報が正しいままかを確かめる対策です。 総務省は完全性を、情報と処理方法が正確で完全な状態を守ることと説明する。改ざんの検出はこれに当たる。 【D(不正解)】 ? 部屋に入れる人を限る物理的な対策です。 許可のない人が情報に近づけないようにする対策で、主に機密性を守る。

    出典: 国民のためのサイバーセキュリティサイト 用語集(か行)(総務省)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  2. 取引先を装い、業務に関係がありそうな添付ファイル付きのメールが、経理部の担当者にだけ届いた。この種類の攻撃は?

    A. DoS 攻撃 B. 標的型攻撃 C. ゼロデイ攻撃 D. DNS キャッシュポイズニング

    答えと解説

    正解: B 【A(不正解)】 ? 大量の要求でサービスを止める攻撃です。 サービスを使えなくする攻撃で、特定の担当者へだますメールを送る手口とは違う。 【B(正解)】 ? 特定の組織を狙って情報を盗もうとする攻撃です。 総務省は、特定の組織を狙い機密情報などを盗もうとする攻撃と説明する。業務を装ったメールが入口になりやすい。 【C(不正解)】 ? 修正プログラムが出る前の脆弱性を突く攻撃です。 脆弱性が直されていない期間を狙う攻撃の呼び名で、問題の状況はメールで特定の人を狙う点が特徴である。 【D(不正解)】 ? DNS に偽の情報を覚えさせる攻撃です。 名前解決をだまして偽サイトへ誘導する攻撃で、添付ファイル付きのメールとは関係がない。

    出典: 国民のためのサイバーセキュリティサイト 用語集(は行)(総務省)/国民のためのサイバーセキュリティサイト 用語集(英字)(総務省)

    この問題へのリンク
  3. あるソフトウェアの脆弱性が公表されたが、メーカーの修正プログラムはまだ配布されていない。この期間に、その脆弱性を突いて行われる攻撃は?

    A. ゼロデイ攻撃 B. パスワードリスト攻撃 C. セッションハイジャック D. ソーシャルエンジニアリング

    答えと解説

    正解: A 【A(正解)】 ? 「0 日」を意味する英語に由来する名前の攻撃です。 総務省は、修正プログラムが配布される前に脆弱性を利用する攻撃をゼロデイ攻撃と説明する。 【B(不正解)】 ? 他で漏れた ID とパスワードを試す攻撃です。 流出した認証情報を使い回す攻撃で、ソフトウェアの脆弱性を突くものではない。 【C(不正解)】 ? 通信の途中で利用者になりすます攻撃です。 通信を乗っ取る攻撃の呼び名で、修正前の脆弱性という時期に着目した呼び名ではない。 【D(不正解)】 ? 人の心理的な隙につけ込む手口です。 人をだまして情報を得る手口で、ソフトウェアの脆弱性を直接突くものではない。

    出典: 脆弱性(ぜいじゃくせい)とは?(総務省 国民のためのサイバーセキュリティサイト)

    この問題へのリンク
  4. ある通販サイトから漏れた ID とパスワードの組を使い、別の会社の会員サイトへのログインが大量に試された。この攻撃は?

    A. ブルートフォース攻撃 B. 辞書攻撃 C. パスワードリスト攻撃 D. クロスサイトスクリプティング

    答えと解説

    正解: C 【A(不正解)】 ? パスワードの候補をすべて順に試す攻撃です。 考えられる文字の組合せを総当たりで試す攻撃で、漏れた組をそのまま使う手口とは違う。 【B(不正解)】 ? 辞書にある単語をパスワードの候補として試す攻撃です。 よく使われる単語を候補にする攻撃で、他のサイトで漏れた組を使う手口とは違う。 【C(正解)】 ? ID とパスワードの組の一覧を使ってログインを試す攻撃です。 総務省は、流出したアカウント情報で他のサービスへの不正ログインを試す手口を挙げ、使い回しをやめるよう勧める。 【D(不正解)】 ? Web ページにスクリプトを埋め込む攻撃です。 閲覧者のブラウザでスクリプトを動かす攻撃で、ログインを試す攻撃ではない。

    出典: 安全なパスワードの設定・管理(総務省 国民のためのサイバーセキュリティサイト)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  5. ファイル名を URL で受け取って表示する Web アプリで、「../../」を含む値を送られ、公開していない設定ファイルが読まれた。この攻撃は?

    A. SQL インジェクション B. ディレクトリトラバーサル C. OS コマンドインジェクション D. クロスサイトリクエストフォージェリ

    答えと解説

    正解: B 【A(不正解)】 ? SQL 文を不正に組み立てさせる攻撃です。 データベースへの命令を操る攻撃で、サーバ内のファイルを指定する手口とは違う。 【B(正解)】 ? 上位のフォルダへたどってファイルを指定する攻撃です。 IPA は、外部からのパラメータでファイル名を直接指定する実装を突かれ、任意のファイルを読まれる脆弱性と説明する。 【C(不正解)】 ? サーバの OS のコマンドを実行させる攻撃です。 OS のコマンドを不正に実行させる攻撃で、「../」でファイルを指定する手口とは違う。 【D(不正解)】 ? ログイン中の利用者に意図しない処理をさせる攻撃です。 利用者のブラウザから意図しないリクエストを送らせる攻撃で、サーバ内のファイルは直接読まない。

    出典: 安全なウェブサイトの作り方 1.3 パス名パラメータの未チェック/ディレクトリ・トラバーサル(IPA)

    この問題へのリンク
  6. カフェの無線 LAN で、利用者と Web サーバの通信の間に第三者が割り込み、やり取りを盗み見たり書き換えたりした。この攻撃は?

    A. 中間者攻撃 B. DoS 攻撃 C. ブルートフォース攻撃 D. ゼロデイ攻撃

    答えと解説

    正解: A 【A(正解)】 ? 英語では Man-in-the-Middle 攻撃と呼ばれる攻撃です。 総務省は、当事者の間に悪意のある第三者が割り込んで不正を行う攻撃と説明する。英語では Man-in-the-Middle 攻撃という。 【B(不正解)】 ? 大量の要求でサービスを止める攻撃です。 サービスを止めることが目的の攻撃で、通信の中身を読み書きする攻撃ではない。 【C(不正解)】 ? パスワードの候補を総当たりで試す攻撃です。 パスワードを推測する攻撃で、通信の途中に割り込むものではない。 【D(不正解)】 ? 修正前の脆弱性を突く攻撃です。 脆弱性が直される前の期間をねらう攻撃の呼び名で、通信に割り込む手口の名前ではない。

    出典: 国民のためのサイバーセキュリティサイト 用語集(た行)(総務省)

    この問題へのリンク
  7. 経費の不正な精算が起きた。調べると「営業ノルマが厳しい」「承認者が中身を見ずに承認していた」「皆やっていると思った」の 3 点が分かった。「承認者が中身を見ずに承認」は不正のトライアングルのどれに当たるか?

    A. 動機(プレッシャー) B. 正当化 C. 脆弱性 D. 機会

    答えと解説

    正解: D 【A(不正解)】 ? 不正をしたくなる事情や圧力です。 ノルマの厳しさのような、不正に向かわせる事情が動機に当たる。承認の甘さは別の要素である。 【B(不正解)】 ? 不正を自分に納得させる理由づけです。 「皆やっている」のような自分勝手な理由づけが正当化に当たる。承認の甘さは別の要素である。 【C(不正解)】 ? 情報資産の側にある弱点を指す言葉です。 脆弱性は情報セキュリティの用語だが、不正のトライアングルの 3 要素には入らない。 【D(正解)】 ? 不正ができてしまう環境のことです。 中身を確かめない承認は、不正を実行しやすくする環境で機会に当たる。IPA は 3 要素を減らすことを勧めている。

    出典: IPA NEWS Vol.64(2023 年 12 月号)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  8. 社員が正しい URL を入力したのに、本物そっくりの偽サイトが表示された。調べると、社内の DNS キャッシュサーバに偽の対応情報が記録されていた。この攻撃は?

    A. フィッシング B. DNS キャッシュポイズニング C. セッションハイジャック D. SQL インジェクション

    答えと解説

    正解: B 【A(不正解)】 ? 偽のメールなどで偽サイトへ誘う手口です。 フィッシングは主にメールなどで偽サイトへ誘う。正しい URL を入れても誘導されたのは名前解決がだまされたためである。 【B(正解)】 ? 名前解決の仕組みを狙う攻撃です。 総務省は、DNS に偽の情報を流し込み、意図しないサーバへ誘導する攻撃と説明する。キャッシュサーバの偽情報が手がかりになる。 【C(不正解)】 ? 利用者とサーバの通信を乗っ取る攻撃です。 確立したセッションを乗っ取る攻撃で、DNS の対応情報をすり替えるものではない。 【D(不正解)】 ? SQL 文を不正に組み立てさせる攻撃です。 データベースを不正に操作する攻撃で、名前解決の結果は変えない。

    出典: 国民のためのサイバーセキュリティサイト 用語集(英字)(総務省)

    この問題へのリンク

暗号・認証などの情報セキュリティ技術

  1. 10 人のメンバーが、2 人ずつ別々の鍵で秘密の通信をする。共通鍵暗号方式で全員が互いに通信できるようにするとき、必要な鍵の数は?

    A. 10 個 B. 20 個 C. 45 個 D. 90 個

    答えと解説

    正解: C 【A(不正解)】 ? 人数と同じ数です。 1 人 1 個では、2 人の組ごとに別の鍵にならない。組の数だけ鍵が要る。 【B(不正解)】 ? 人数の 2 倍の数です。 これは公開鍵暗号方式で全員が公開鍵と秘密鍵を 1 組ずつ持つときの数(10×2)である。 【C(正解)】 ? 2 人の組合せの数です。 2 人の組ごとに同じ鍵を共有するので 10×9÷2=45 個要る。共通鍵暗号は暗号化と復号に同じ鍵を使う。 【D(不正解)】 ? 人数×(人数−1)の数です。 10×9=90 は組を 2 回数えている。A と B の組と B と A の組は同じ鍵なので 2 で割る。

    出典: 国民のためのサイバーセキュリティサイト 用語集(か行)(総務省)/情報漏えいを防ぐためのモバイルデバイス等設定マニュアル 解説編(IPA)

    この問題へのリンク
  2. 大きな設計図のファイルを取引先へ安全に送りたい。暗号化の速さと、鍵を安全に渡すことの両方を満たす方法として適切なものは?

    A. ファイルを受信者の秘密鍵で暗号化し、受信者の公開鍵で復号してもらう B. ファイルを共通鍵で暗号化し、その共通鍵を受信者の公開鍵で暗号化して送る C. ファイルを送信者の公開鍵で暗号化し、送信者の秘密鍵を一緒に送る D. ファイルのハッシュ値を計算して送り、受信者に元のファイルへ戻してもらう

    答えと解説

    正解: B 【A(不正解)】 ? 受信者の鍵の組の使い方です。 受信者の秘密鍵は受信者しか持たないので、送信者は使えない。暗号化には受信者の公開鍵を使う。 【B(正解)】 ? 2 種類の暗号を組み合わせる方法です。 ハイブリッド暗号の方法である。RFC 5652 でも、中身は乱数で作った鍵で暗号化し、その鍵を受信者の公開鍵で暗号化する。 【C(不正解)】 ? 送信者の鍵の組の使い方です。 秘密鍵を送ると誰でも復号できるので、安全な鍵の受け渡しにならない。 【D(不正解)】 ? 固定長の値を作る関数の使い方です。 ハッシュ関数は一方向の関数で、ハッシュ値から元のデータには戻せない。

    出典: RFC 5652 Cryptographic Message Syntax (CMS)/国民のためのサイバーセキュリティサイト 用語集(か行)(総務省)

    この問題へのリンク
  3. 総務課の担当者が、発行した通知文にディジタル署名を付ける。署名の作成と検証に使う鍵の組合せとして適切なものは?

    A. 受信者の公開鍵で作成し、受信者の秘密鍵で検証する B. 送信者の公開鍵で作成し、送信者の秘密鍵で検証する C. 送信者と受信者で共有した共通鍵で作成し、同じ鍵で検証する D. 送信者の秘密鍵で作成し、送信者の公開鍵で検証する

    答えと解説

    正解: D 【A(不正解)】 ? 受信者の鍵の組を使う組合せです。 受信者の鍵で作ると、送信者が本人であることを示せない。これは暗号化で秘密を守るときの鍵の使い方に近い。 【B(不正解)】 ? 送信者の鍵の組を逆に使う組合せです。 公開鍵は誰でも持てるので、公開鍵で作った署名では本人を確かめられない。 【C(不正解)】 ? 1 つの鍵を 2 者で共有する組合せです。 共通鍵は双方が持つので、どちらが作ったかを第三者に示せない。これはメッセージ認証符号の考え方である。 【D(正解)】 ? 持ち主しか持たない鍵で作る組合せです。 総務省は、作成者が秘密鍵で署名し、受信者が公開鍵で検証すると説明する。改ざんの検出と否認防止ができる。

    出典: 国民のためのサイバーセキュリティサイト 用語集(た行)(総務省)

    この問題へのリンク
  4. 退職した社員のクライアント証明書を、有効期限の前に失効させた。接続を受けるサーバが、その証明書が失効していることを確かめる手段として適切なものは?

    A. 証明書に書かれた有効期限の日付を確認する B. 認証局が発行する CRL を参照する C. 証明書の公開鍵の長さが基準を満たすかを確認する D. サーバのルート証明書を入れ直す

    答えと解説

    正解: B 【A(不正解)】 ? 証明書そのものに書かれた期間の確認です。 失効は有効期限より前に起こるので、期限の日付だけでは失効を見つけられない。 【B(正解)】 ? 失効した証明書を並べたリストの参照です。 RFC 5280 は、CRL を認証局などが署名した、失効した証明書を示す時刻付きのリストと定める。OCSP で問い合わせる方法もある。 【C(不正解)】 ? 鍵の強さの確認です。 鍵の長さは暗号の強さの目安で、その証明書が失効したかどうかは分からない。 【D(不正解)】 ? 信頼の起点となる証明書の入れ替えです。 ルート証明書を入れ直しても、個々の証明書の失効は分からない。

    出典: RFC 5280 Internet X.509 PKI Certificate and CRL Profile/RFC 6960 X.509 Internet PKI Online Certificate Status Protocol - OCSP

    この問題へのリンク
  5. 社内システムのログインで、パスワードそのものをネットワークに流さずに本人確認をしたい。サーバが毎回違う乱数を送り、端末がそれと秘密の情報から計算した値を返す方式は?

    A. チャレンジレスポンス認証 B. 多要素認証 C. シングルサインオン D. 生体認証

    答えと解説

    正解: A 【A(正解)】 ? 問いかけと応答の組で本人を確かめる方式です。 RFC 1994 の CHAP では、秘密の情報は回線に流れない。問いかけが毎回変わるので、盗んだ応答を再利用しにくい。 【B(不正解)】 ? 異なる種類の要素を 2 つ以上組み合わせる方式です。 知識・所持・生体のうち 2 つ以上を使う考え方で、問題の乱数のやり取りそのものを指す名前ではない。 【C(不正解)】 ? 1 回の認証で複数のシステムを使えるようにする方式です。 利用者の手間を減らす仕組みで、パスワードを流さないための計算方式ではない。 【D(不正解)】 ? 体の特徴を使って本人を確かめる方式です。 指紋などの体の特徴を使う方式で、乱数と秘密の情報から値を計算する方式ではない。

    出典: RFC 1994 PPP Challenge Handshake Authentication Protocol (CHAP)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  6. 入室ゲートの指紋認証で、照合のしきい値を厳しくし、より高い一致度を求めるようにした。起こりやすくなる変化として適切なものは?

    A. 他人受入率も本人拒否率も、ともに下がる B. 他人受入率は上がるが、本人拒否率は下がる C. しきい値を変えても、2 つの率は変わらない D. 他人受入率は下がるが、本人拒否率は上がる

    答えと解説

    正解: D 【A(不正解)】 ? 2 つの率が同じ向きに動くという見方です。 IPA は、他人受入率を下げると本人拒否率が上がる特性があると説明する。両方は下がりにくい。 【B(不正解)】 ? 一致度を緩めたときの変化です。 求める一致度を下げると、他人を受け入れやすくなり、本人は通りやすくなる。問題の設定とは逆である。 【C(不正解)】 ? 認証の精度が設定に左右されないという見方です。 IPA は、認証精度は製品ごとに設定されており、設定を変えて他人受入率を下げられると説明する。しきい値は 2 つの率に影響する。 【D(正解)】 ? 一致度を厳しくしたときの変化です。 高い一致度を求めると他人は通りにくくなる。一方、指のずれなどで本人も拒否されやすくなる。

    出典: 情報漏えいを防ぐためのモバイルデバイス等設定マニュアル 解説編(IPA)

    この問題へのリンク
  7. 会員サイトでパスワードをハッシュ値にして保存する。同じパスワードの利用者でも別のハッシュ値になるよう、利用者ごとに加える値は?

    A. ソルト B. ポート番号 C. パリティビット D. CRL

    答えと解説

    正解: A 【A(正解)】 ? パスワードに加えるランダムな値です。 RFC 8018 は、ソルトにより同じパスワードから違う鍵ができ、事前に計算した表を使う攻撃が難しくなると書く。 【B(不正解)】 ? 通信でアプリケーションを区別する番号です。 ポート番号は通信で使う番号で、ハッシュ値を利用者ごとに変えるためのものではない。 【C(不正解)】 ? データの化けを見つけるために足すビットです。 伝送などの誤りを見つけるためのビットで、パスワードの保存を強くするものではない。 【D(不正解)】 ? 失効した証明書の一覧です。 証明書の失効を確かめるためのリストで、パスワードのハッシュ値とは関係がない。

    出典: RFC 8018 PKCS #5: Password-Based Cryptography Specification Version 2.1/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  8. 取引先と共有した鍵で、注文データに HMAC によるメッセージ認証符号を付けて送った。この方法だけでは実現できないことは?

    A. 通信の途中で注文データが書き換えられていないことを確かめる B. 共有した鍵を持つ相手が作ったデータであることを確かめる C. 送信者がどちらかを第三者に示し、送信者に否認させない D. 受信者が同じ鍵を使って値を計算し直し、届いた値と比べる

    答えと解説

    正解: C 【A(不正解)】 ? データが変わっていないかの確認です。 受信者は同じ鍵で値を計算し直して比べるので、改ざんを見つけられる。 【B(不正解)】 ? 鍵を持つ相手から来たかの確認です。 RFC 2104 は、HMAC を秘密の共有鍵とハッシュ関数によるメッセージ認証の仕組みとしている。鍵を持つ者が作ったことは確かめられる。 【C(正解)】 ? 第三者に向けた証明です。 鍵は双方が持つので、受信者も同じ値を作れる。第三者への証明と否認防止には、秘密鍵で作るディジタル署名を使う。 【D(不正解)】 ? 受信側での検証の手順です。 共有鍵で同じ計算をして比べるのが検証の手順で、この方法で行える。

    出典: RFC 2104 HMAC: Keyed-Hashing for Message Authentication/RFC 8551 S/MIME Version 4.0 Message Specification

    この問題へのリンク

情報セキュリティ管理

  1. 顧客情報が漏れたときの損害賠償に備えて、情報セキュリティに関する保険に入った。この対応はリスク対応のどれに当たるか?

    A. リスク回避 B. リスク低減 C. リスク移転 D. リスク保有

    答えと解説

    正解: C 【A(不正解)】 ? リスクの原因となる活動をやめる対応です。 保険に入っても、顧客情報を扱う業務はやめていないので回避ではない。 【B(不正解)】 ? 対策でリスクの起こりやすさなどを下げる対応です。 保険は漏えいの起こりやすさを下げるものではないので低減ではない。 【C(正解)】 ? 損失の負担を他社などへ移す対応です。 IPA は、保険への加入や対策の充実した外部サービスの利用を、移転の例に挙げている。 【D(不正解)】 ? 対策をせず、リスクを受け入れる対応です。 保険に入ることで負担を他社に移しているので、そのまま受け入れる保有ではない。

    出典: リスク分析シート 説明資料(IPA 中小企業の情報セキュリティ対策ガイドライン関連)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  2. 廃版製品のカタログは、漏れても事業への影響が小さく、守る対策の費用が想定される損害額を上回る。この情報資産について、IPA の資料に沿った対応は?

    A. 外部接続をやめ、カタログを保存したサーバを社外と切り離す B. 対策を講じず、許容範囲内として現状を維持する C. 保険に入り、損失が出たら保険金で補う D. 暗号化と多要素認証を導入し、漏えいの可能性を下げる

    答えと解説

    正解: B 【A(不正解)】 ? リスクの原因そのものを取り去る対応です。 これはリスク回避の考え方である。費用が損害を上回る資産に、業務を変えてまで行う対応ではない。 【B(正解)】 ? リスクを受け入れる対応です。 IPA は、影響が小さい場合や対策の費用が損害額を上回る場合に、対策せず現状を維持する対応をリスク保有とする。 【C(不正解)】 ? 損失の負担を他社へ移す対応です。 これはリスク移転で、影響の小さい資産のために保険料を払う理由は乏しい。 【D(不正解)】 ? 対策で起こりやすさを下げる対応です。 これはリスク低減で、対策の費用が損害額を上回る状況では選びにくい。

    出典: リスク分析シート 説明資料(IPA 中小企業の情報セキュリティ対策ガイドライン関連)

    この問題へのリンク
  3. IPA の手法で、リスク値=重要度×被害発生可能性として対策の優先度を決める。次の 4 つの情報資産のうち、最も優先して対策すべきものは?

    A. 顧客名簿(重要度 3・被害発生可能性 1) B. 見積書の控え(重要度 2・被害発生可能性 2) C. 社内報の原稿(重要度 1・被害発生可能性 3) D. 受注データ(重要度 3・被害発生可能性 2)

    答えと解説

    正解: D 【A(不正解)】 ? 重要度が最も高い資産です。 リスク値は 3×1=3 である。重要度は高いが、被害発生可能性が低い。 【B(不正解)】 ? 重要度と可能性が中くらいの資産です。 リスク値は 2×2=4 である。 【C(不正解)】 ? 被害発生可能性が最も高い資産です。 リスク値は 1×3=3 である。可能性は高いが、重要度が低い。 【D(正解)】 ? 重要度が高く、可能性も中くらいの資産です。 リスク値は 3×2=6 で、4 つの中で最も大きい。IPA の手法では、リスク値の大きい資産から対策する。

    出典: リスク分析シート 説明資料(IPA 中小企業の情報セキュリティ対策ガイドライン関連)

    この問題へのリンク
  4. 情報の機密性や完全性、可用性を守るために、組織の方針や行動の指針をまとめたものは?

    A. サービスレベル合意書(SLA) B. 情報セキュリティポリシー C. 提案依頼書(RFP) D. 作業分解構成図(WBS)

    答えと解説

    正解: B 【A(不正解)】 ? サービスの提供者と利用者が品質の水準を取り決める文書です。 サービスの水準の合意で、組織の情報セキュリティの方針をまとめたものではない。 【B(正解)】 ? 組織として情報をどう守るかを定めた方針です。 総務省は、情報の機密性・完全性・可用性を維持するための組織の方針や行動指針をまとめたものと説明する。 【C(不正解)】 ? 発注先の候補に提案を求める文書です。 システムの調達で使う提案依頼書で、情報セキュリティの方針ではない。 【D(不正解)】 ? 作業を細かく分けて階層で表したものです。 プロジェクトの作業分解の図で、情報セキュリティの方針ではない。

    出典: 国民のためのサイバーセキュリティサイト 用語集(さ行)(総務省)

    この問題へのリンク
  5. 自社の ISMS について、ISMS-AC が認定した認証機関の審査を受けて ISMS 認証を取りたい。審査で適合を確かめる基準となる規格は?

    A. ISO/IEC 15408 B. CVSS C. JIS Q 27001 D. IT 製品の調達におけるセキュリティ要件リスト

    答えと解説

    正解: C 【A(不正解)】 ? IT 製品のセキュリティを評価する国際基準です。 製品やシステムのセキュリティ品質を評価する基準で、組織の ISMS の認証基準ではない。 【B(不正解)】 ? 脆弱性の深刻度を数値で表す評価手法です。 個々の脆弱性を評価するもので、組織の管理の仕組みを審査する基準ではない。 【C(正解)】 ? 情報セキュリティマネジメントシステムの要求事項の規格です。 ISMS-AC は、ISMS 適合性評価制度の認証基準を JIS Q 27001(ISO/IEC 27001)としている。 【D(不正解)】 ? 政府機関が機器を調達するときに参照する要件の一覧です。 IPA は、政府の機器調達で参照する一覧と説明する。組織の ISMS の認証基準ではない。

    出典: ISMS 適合性評価制度の概要(ISMS-AC)/IT セキュリティ評価及び認証制度(JISEC)について(IPA)

    この問題へのリンク
  6. マルウェア感染の連絡を受けたら、社内外と調整しながら対応を進める専門のチームを作りたい。このチームの呼び名として適切なものは?

    A. CSIRT B. ISMS C. WAF D. CVSS

    答えと解説

    正解: A 【A(正解)】 ? 組織内でインシデントに対応するチームです。 JPCERT/CC は、CSIRT を組織内の情報セキュリティ問題を専門に扱うインシデント対応チームと説明する。 【B(不正解)】 ? 情報セキュリティを継続して管理し改善する仕組みです。 組織全体の管理の仕組みの呼び名で、インシデントに対応するチームの名前ではない。 【C(不正解)】 ? Web アプリケーションへの攻撃を防ぐ仕組みです。 通信を検査する製品や機能で、人が集まって対応するチームではない。 【D(不正解)】 ? 脆弱性の深刻度を表す評価手法です。 脆弱性を評価する手法で、インシデントに対応する組織の名前ではない。

    出典: CSIRT マテリアル(JPCERT/CC)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  7. 製品の開発データについて、開発部には閲覧・編集・削除を認め、営業部には閲覧だけを認め、他部署には権限を与えないことにした。この考え方は?

    A. 多層防御 B. 最小権限の原則 C. フェールセーフ D. シングルサインオン

    答えと解説

    正解: B 【A(不正解)】 ? 複数の対策を重ねて守る考え方です。 防御を何層も重ねる考え方で、部署ごとに権限を絞る考え方そのものではない。 【B(正解)】 ? 仕事に必要な範囲だけの権限を与える考え方です。 need-to-know の原則ともいう。総務省は、必要な利用者にだけ必要最低限のアクセスを許すことが大切だとし、部門ごとの分け方を例に挙げる。 【C(不正解)】 ? 故障のときに安全な側へ倒れるようにする考え方です。 故障時の安全を確保する設計の考え方で、アクセス権の分け方ではない。 【D(不正解)】 ? 1 回の認証で複数のシステムを使えるようにする仕組みです。 認証の手間を減らす仕組みで、権限の範囲を絞る考え方ではない。

    出典: アクセス制御・管理(総務省 国民のためのサイバーセキュリティサイト)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク

セキュリティ技術評価と情報セキュリティ対策

  1. IT 製品のセキュリティ機能を第三者が評価・認証するための国際評価基準で、日本では JISEC の評価・認証の基準になっているものは?

    A. ISO/IEC 15408 B. JIS Q 27001 C. CVSS D. OSI 基本参照モデル

    答えと解説

    正解: A 【A(正解)】 ? コモンクライテリアとも呼ばれる評価基準です。 IPA は、政府の調達で ISO/IEC 15408(CC)に基づく評価・認証を受けた製品の利用が進められていると説明する。 【B(不正解)】 ? 組織の ISMS の要求事項の規格です。 組織の情報セキュリティマネジメントの規格で、製品を評価する基準ではない。 【C(不正解)】 ? 脆弱性の深刻度を数値で表す手法です。 個々の脆弱性の深刻度を表すもので、製品のセキュリティ機能を認証する基準ではない。 【D(不正解)】 ? 通信の機能を 7 つの階層に分けたモデルです。 ネットワークの階層モデルで、セキュリティ評価の基準ではない。

    出典: IT セキュリティ評価及び認証制度(JISEC)について(IPA)/国民のためのサイバーセキュリティサイト 用語集(英字)(総務省)

    この問題へのリンク
  2. 公表された脆弱性の CVSS 基本値は高い。自社では対象の機能を使わず、インターネットからも届かない。自社にとっての深刻度を評価し直すために使う CVSS v3 の基準は?

    A. 基本評価基準 B. 現状評価基準 C. ISO/IEC 15408 の評価保証レベル D. 環境評価基準

    答えと解説

    正解: D 【A(不正解)】 ? 脆弱性そのものの特性を評価する基準です。 時間や環境で変わらない、脆弱性そのものの評価である。自社の環境は加味しない。 【B(不正解)】 ? 攻撃コードや対策情報の今の状況を評価する基準です。 時間とともに変わる状況を評価するもので、自社の環境は加味しない。 【C(不正解)】 ? 製品の評価の確からしさの段階です。 製品の評価・認証で使う考え方で、CVSS の基準ではない。 【D(正解)】 ? 利用者の環境での深刻度を評価する基準です。 IPA は、利用者の環境での深刻度を、脅威やセキュリティ要求度、緩和策を加味して評価すると説明する。

    出典: 共通脆弱性評価システム CVSS v3 概説(IPA)

    この問題へのリンク
  3. 攻撃者と同じ視点で実際に攻撃を試み、社内システムに侵入して目的を達成できるかを確かめたい。この検査として適切なものは?

    A. ペネトレーションテスト B. 脆弱性診断 C. ファジング D. 回帰テスト

    答えと解説

    正解: A 【A(正解)】 ? 侵入テストとも呼ばれる検査です。 総務省は、攻撃者と同じ視点で攻撃し、成功するかをリスクベースで確かめる検査と説明する。被害の程度も分かる。 【B(不正解)】 ? システムの弱点を網羅的に洗い出す検査です。 対象全体を広く調べて弱点を見つける検査で、攻撃の流れに沿って目的を達成できるかまでは確かめない。 【C(不正解)】 ? 問題を起こしそうなデータを大量に送る検査です。 製品が異常終了するかなどから未知の脆弱性を探す手法で、侵入の成否を確かめる検査ではない。 【D(不正解)】 ? 変更で他の部分に不具合が出ていないかを確かめるテストです。 プログラムの変更による影響を確かめるテストで、攻撃を試す検査ではない。

    出典: 脆弱性診断・ペネトレーションテスト(総務省 国民のためのサイバーセキュリティサイト)

    この問題へのリンク
  4. 社内ネットワークの出入口で、不正と判断した通信を見つけるだけでなく、その場で遮断したい。通信の経路上に置いて使う製品として適切なものは?

    A. IDS B. IPS C. SIEM D. MDM

    答えと解説

    正解: B 【A(不正解)】 ? 不正な侵入を検知するシステムです。 侵入を検知して知らせるのが主な役割である。遮断までを行うのは、IPS の機能である。 【B(正解)】 ? 不正な侵入を防止するシステムです。 IPA の手引書は、経路上に置くインライン型なら不正と判断したパケットを遮断できると説明する。この遮断する防御機能を IPS 機能と呼ぶ。 【C(不正解)】 ? 多数の機器のログを集めて分析する仕組みです。 ログを集めて相関分析し脅威に気づく仕組みで、経路上で通信を遮断する製品ではない。 【D(不正解)】 ? スマートフォンなどの端末を管理する仕組みです。 携帯端末を安全に管理する仕組みで、ネットワークの出入口の通信は遮断しない。

    出典: 産業用制御システム向け侵入検知製品等の導入手引書(IPA・令和 5 年 6 月)/国民のためのサイバーセキュリティサイト 用語集(英字)(総務省)

    この問題へのリンク
  5. 侵入検知製品で「異常な通信」の定義を広く取りすぎた。このとき起こりやすくなることとして適切なものは?

    A. フォールスネガティブが増え、攻撃の通信を見逃しやすくなる B. 正常な通信も異常な通信も、すべて検知されなくなる C. 誤った判定がすべてなくなり、調べる手間も減る D. フォールスポジティブが増え、正常な通信まで警告が出やすくなる

    答えと解説

    正解: D 【A(不正解)】 ? 異常なものを正常と判定してしまうことです。 定義を広く取ると見逃しは減る。見逃しが増えるのは、定義を狭く絞りすぎたときである。 【B(不正解)】 ? 検知が止まるという見方です。 定義を広げても検知が止まるわけではない。むしろ検知の件数は増えやすい。 【C(不正解)】 ? 判定のずれが無くなるという見方です。 IPA の手引書は、定義の広さと誤検知・検知漏れは一方を減らすと他方が増える関係だと説明する。 【D(正解)】 ? 正常なものを異常と判定してしまうことです。 IPA の手引書は、定義を広く取りすぎると、正常な通信を異常とする誤検知(偽陽性)が増えると説明する。

    出典: 産業用制御システム向け侵入検知製品等の導入手引書(IPA・令和 5 年 6 月)

    この問題へのリンク
  6. IC カードの中の暗号鍵を、分解や消費電力の測定などで外から解析されにくくしたい。このような性質を表す言葉は?

    A. 可用性 B. 耐タンパ性 C. フォールトトレラント D. ユーザビリティ

    答えと解説

    正解: B 【A(不正解)】 ? 必要なときに使える性質です。 必要なときに情報を使える性質で、内部を解析されにくい性質ではない。 【B(正解)】 ? 英語の tamper(不正にいじる)に由来する言葉です。 政府機関等のガイドラインは、暗号処理や署名処理を行う装置などの、外部からの解読攻撃に対する耐性と定義する。 【C(不正解)】 ? 故障しても機能を続けられる性質です。 故障に強い設計の考え方で、攻撃者による解析への強さを表す言葉ではない。 【D(不正解)】 ? 使いやすさを表す言葉です。 利用者にとっての使いやすさで、暗号鍵を守る性質ではない。

    出典: 政府機関等の対策基準策定のためのガイドライン(令和 7 年度版)用語定義(内閣官房 国家サイバー統括室)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  7. ランサムウェアに感染し、同じネットワーク上のバックアップまで暗号化された。再発に備えたバックアップの改善として適切なものは?

    A. バックアップ先を本番と同じフォルダに移し、毎時上書きする B. バックアップをやめ、マルウェア対策ソフトの定義ファイル更新だけにする C. バックアップを本番とネットワーク上で分離し、オフラインでも保管して復旧訓練をする D. バックアップを暗号化し、鍵を本番サーバの中に保存する

    答えと解説

    正解: C 【A(不正解)】 ? バックアップの置き場所と頻度を変える案です。 本番と同じ場所では、感染すると一緒に暗号化される。上書きすると感染前の状態にも戻せない。 【B(不正解)】 ? 感染を防ぐ対策に絞る案です。 定義ファイルの更新は大切だが、感染を完全には防げない。復旧の手段が無くなる。 【C(正解)】 ? 置き場所を分け、戻す練習もする案です。 総務省は、同じネットワークにつなぐと共倒れの危険が高まるとし、オフラインでの保管と戻す訓練を勧める。 【D(不正解)】 ? バックアップの中身を守る案です。 鍵が本番サーバにあると、感染時に鍵ごと使えなくなるおそれがある。分離の考え方に合わない。

    出典: データ復旧・バックアップの管理(総務省 国民のためのサイバーセキュリティサイト)/基本情報技術者試験(レベル 2)シラバス Ver.9.2(IPA)

    この問題へのリンク
  8. ファイアウォールやサーバ、IDS などのログを 1 か所に集め、複数の機器にまたがる出来事の関連を自動で分析して脅威に気づきたい。使う仕組みは?

    A. SIEM B. NTP C. WAF D. MDM

    答えと解説

    正解: A 【A(正解)】 ? セキュリティの情報とイベントを一元管理する仕組みの略称です。 IPA の手引書は、SIEM を使ってアラートや各種ログを自動で相関分析する運用を紹介している。 【B(不正解)】 ? 機器の時計を合わせる仕組みです。 時刻をそろえるとログの突き合わせはしやすくなるが、ログを集めて分析する仕組みではない。 【C(不正解)】 ? Web アプリケーションへの攻撃を防ぐ仕組みです。 Web への通信を検査して止めるもので、多数の機器のログを集めて分析する仕組みではない。 【D(不正解)】 ? 携帯端末を管理する仕組みです。 スマートフォンなどを管理する仕組みで、ログの相関分析はしない。

    出典: 産業用制御システム向け侵入検知製品等の導入手引書(IPA・令和 5 年 6 月)/監査ログの管理(総務省 国民のためのサイバーセキュリティサイト)

    この問題へのリンク

セキュリティ実装技術

  1. Web アプリで、検索欄に入れた文字列をつなげて SQL 文を作っている。SQL インジェクションへの根本的な対策として、IPA が勧めるものは?

    A. 入力された文字列を画面に出すときに HTML のエスケープ処理をする B. データベースのエラーメッセージを画面に出さないようにする C. プレースホルダを使って SQL 文を組み立てる D. Cookie に HttpOnly 属性を付ける

    答えと解説

    正解: C 【A(不正解)】 ? 画面に出力するときの対策です。 これはクロスサイトスクリプティングへの対策で、SQL 文の組み立ての問題は解決しない。 【B(不正解)】 ? 攻撃の手がかりを減らす対策です。 IPA はこれを保険的な対策としている。SQL 文の組み立てを直す根本的な対策ではない。 【C(正解)】 ? SQL 文の変数部分を記号にしておく方法です。 IPA は、プレースホルダで SQL 文を組み立てる方法を根本的な解決としている。静的プレースホルダなら原理的に脆弱性が無くなる。 【D(不正解)】 ? スクリプトから Cookie を読めなくする設定です。 Cookie の盗み取りを減らす設定で、SQL 文の組み立ての問題には効かない。

    出典: 安全なウェブサイトの作り方 1.1 SQL インジェクション(IPA)

    この問題へのリンク
  2. 掲示板アプリで、利用者が書き込んだ文字列をそのまま Web ページに出している。クロスサイトスクリプティングへの根本的な対策は?

    A. Web ページに出力するすべての要素にエスケープ処理をする B. Cookie に HttpOnly 属性を付ける C. SQL 文をプレースホルダで組み立てる D. ファイル名から basename() でディレクトリ名を取り除く

    答えと解説

    正解: A 【A(正解)】 ? 特殊な記号を文字として表示させる処理です。 IPA は、ページに出力する全ての要素にエスケープ処理をすることを根本的な解決としている。 【B(不正解)】 ? スクリプトから Cookie を読めなくする設定です。 IPA はこれを保険的な対策としている。スクリプトが埋め込まれること自体は防げない。 【C(不正解)】 ? SQL 文の変数部分を記号にする方法です。 SQL インジェクションへの対策で、ページへの出力の問題は解決しない。 【D(不正解)】 ? パス名からファイル名だけを取り出す処理です。 ディレクトリトラバーサルへの対策で、スクリプトの埋め込みは防げない。

    出典: 安全なウェブサイトの作り方 1.5 クロスサイト・スクリプティング(IPA)

    この問題へのリンク
  3. ネット銀行で、ログイン中の利用者が罠のページを開くと、本人の意図しない送金が実行された。クロスサイトリクエストフォージェリへの根本的な対策は?

    A. 出力する文字列をすべてエスケープ処理する B. データベースのアカウントの権限を必要最小限にする C. 送金後に、登録したメールアドレスへ通知を送る D. 実行画面に推測されにくい秘密情報を埋め込み、送られた値と照合する

    答えと解説

    正解: D 【A(不正解)】 ? 画面に出す文字を安全にする処理です。 クロスサイトスクリプティングへの対策で、意図しないリクエストを見分ける仕組みにはならない。 【B(不正解)】 ? データベース側の被害を抑える設定です。 SQL インジェクションの保険的対策で、意図しない送金リクエストは見分けられない。 【C(不正解)】 ? 事後に利用者へ知らせる仕組みです。 IPA はこれを保険的な対策とする。メールの通知は事後の処理で、攻撃そのものは防げない。 【D(正解)】 ? 正規の画面からの操作かを確かめる仕組みです。 IPA は、hidden パラメータに秘密情報を埋め込み、一致したときだけ処理する方法を根本的な解決としている。

    出典: 安全なウェブサイトの作り方 1.6 CSRF(クロスサイト・リクエスト・フォージェリ)(IPA)

    この問題へのリンク
  4. 自社ドメインをかたるメールが出回った。受信側に、SPF と DKIM の検証に通らないメールを隔離や拒否してほしいと、DNS で宣言したい。使う仕組みは?

    A. S/MIME B. DMARC C. DNSSEC D. OAuth

    答えと解説

    正解: B 【A(不正解)】 ? メールに署名や暗号化をする仕組みです。 送信者がメール自体に署名・暗号化する仕組みで、ドメインの扱いの方針を DNS で宣言するものではない。 【B(正解)】 ? 送信ドメイン認証の結果の扱いと報告の方法を定める仕組みです。 RFC 9989 は、ドメインの持ち主が none・quarantine・reject などの方針を示せると定める。合格には SPF か DKIM の合格と識別子の一致が要る。 【C(不正解)】 ? DNS の応答に署名を付ける仕組みです。 DNS の応答の正しさを確かめる仕組みで、なりすましメールの扱いの方針は宣言しない。 【D(不正解)】 ? 他のサービスに限られた権限を与える仕組みです。 アプリにアクセスの権限を与える仕組みで、メールの送信ドメイン認証ではない。

    出典: RFC 9989 Domain-Based Message Authentication, Reporting, and Conformance (DMARC)/電子メールと Web サイトにおける対策(総務省 国民のためのサイバーセキュリティサイト)

    この問題へのリンク
  5. DNS の応答が途中で書き換えられていないことと、正しい発信元からの応答であることを確かめたい。DNS に追加する仕組みとして適切なものは?

    A. DNSSEC B. SPF C. NAT D. SNMP

    答えと解説

    正解: A 【A(正解)】 ? DNS の情報にディジタル署名を付ける拡張です。 RFC 4033 は、DNSSEC がデータの発信元の認証と完全性を加えると書く。なお、通信内容の秘匿はしない。 【B(不正解)】 ? メールの送信元サーバを DNS で確かめる仕組みです。 メールの送信元を確かめる仕組みで、DNS の応答そのものは守らない。 【C(不正解)】 ? IP アドレスを変換する技術です。 アドレスを変換する技術で、DNS の応答の正しさは確かめられない。 【D(不正解)】 ? ネットワーク機器を監視・管理するプロトコルです。 機器の監視に使うもので、DNS の応答を守る仕組みではない。

    出典: RFC 4033 DNS Security Introduction and Requirements

    この問題へのリンク
  6. 家計簿アプリに、利用者の銀行サイトのパスワードを預けずに、利用者が許可した範囲の明細だけを読ませたい。この目的に使う仕組みは?

    A. RADIUS B. シングルサインオン C. チャレンジレスポンス認証 D. OAuth

    答えと解説

    正解: D 【A(不正解)】 ? ネットワーク接続の認証などを担うプロトコルです。 ネットワークへの接続装置と認証サーバの間で使う仕組みで、Web サービスどうしの権限の受け渡しではない。 【B(不正解)】 ? 1 回の認証で複数のシステムを使う仕組みです。 利用者のログインの手間を減らす仕組みで、アプリに限られた範囲の権限を渡すことが目的ではない。 【C(不正解)】 ? 毎回違う問いかけで本人を確かめる方式です。 本人確認の方式で、アプリに範囲を絞った権限を与える仕組みではない。 【D(正解)】 ? Web サービスで権限を委ねるための認可の枠組みです。 RFC 6749 は、第三者のアプリが HTTP のサービスへの限られたアクセスを得る枠組みとする。パスワードの代わりにアクセストークンを使う。

    出典: RFC 6749 The OAuth 2.0 Authorization Framework

    この問題へのリンク
  7. 本社と支店のルータ間で IPsec による VPN を作る。元の IP パケット全体を暗号化し、新しい IP ヘッダを付けて送る使い方は?

    A. ESP のトランスポートモード B. AH のトランスポートモード C. ESP のトンネルモード D. SSH のポート転送

    答えと解説

    正解: C 【A(不正解)】 ? 主に IP より上の層を守る使い方です。 RFC 4301 では、トランスポートモードは主に TCP などの上位層を守り、ホストどうしで使う。 【B(不正解)】 ? 改ざんの検出などを行い、暗号化はしない使い方です。 AH は完全性と発信元の認証を提供するが、機密性(暗号化)は提供しない。 【C(正解)】 ? ESP を、トランスポートモードとは別のモードで使う方法です。 RFC 4301 では、トンネルモードは IP パケット全体を守り、新しい外側の IP ヘッダを付ける。暗号化は ESP が行う。 【D(不正解)】 ? SSH の接続の中に別の通信を通す使い方です。 SSH はアプリケーション層の仕組みで、IPsec の使い方ではない。

    出典: RFC 4301 Security Architecture for the Internet Protocol

    この問題へのリンク
  8. 社内の 100 台の PC が、1 つのグローバル IP アドレスを共有してインターネットを使う。アドレスとあわせてポート番号も変換する技術は?

    A. NAPT B. ポート番号を変換しない NAT C. DHCP D. ARP

    答えと解説

    正解: A 【A(正解)】 ? IP マスカレードとも呼ばれる変換の方式です。 RFC 3022 は、NAPT がアドレスに加えて TCP/UDP のポートなども変換し、多くのホストが 1 つのアドレスを共有できると書く。 【B(不正解)】 ? アドレスだけを 1 対 1 で変換する技術です。 RFC 3022 の Basic NAT はアドレスだけを変換するので、同時に使う台数分のグローバルアドレスが要る。 【C(不正解)】 ? IP アドレスなどを自動で配る仕組みです。 社内の PC にアドレスを配る仕組みで、1 つのグローバルアドレスを共有させる変換はしない。 【D(不正解)】 ? IP アドレスから MAC アドレスを求める仕組みです。 同じ LAN の中で相手の MAC アドレスを調べる仕組みで、アドレスの変換はしない。

    出典: RFC 3022 Traditional IP Network Address Translator (Traditional NAT)/RFC 1918 Address Allocation for Private Internets

    この問題へのリンク
  9. 社内の無線 LAN を新しくする。総務省が推奨する暗号化の方式として適切なものは?

    A. WEP B. 暗号化なし(パスワードなしで接続) C. MAC アドレスによる接続制限だけ D. WPA3

    答えと解説

    正解: D 【A(不正解)】 ? 古くからある無線 LAN の暗号化方式です。 総務省は、WEP は短時間で解読される方法が見つかり、安全とは言えないと説明する。 【B(不正解)】 ? 通信を暗号化しない設定です。 通信内容を盗み見られるおそれがあり、社内の無線 LAN には向かない。 【C(不正解)】 ? 接続できる機器を番号で絞る方法です。 接続の制限であり、通信内容の暗号化ではない。 【D(正解)】 ? WPA2 の次に登場した無線 LAN の暗号化方式です。 総務省は、WPA2 または WPA3 による暗号化を推奨し、WPA3 は WPA2 より強固な暗号化方式を使えると説明する。

    出典: 安全な無線 LAN の利用(総務省 国民のためのサイバーセキュリティサイト)

    この問題へのリンク
  10. 家電メーカーが出荷前の製品に、極端に長い文字列など問題を起こしそうなデータを大量に送り、異常終了などの様子から未知の脆弱性を見つけたい。この手法は?

    A. ファジング B. ペネトレーションテスト C. ハニーポット D. SIEM

    答えと解説

    正解: A 【A(正解)】 ? 自動で作った多様な入力を与えて反応を観察する検査手法です。 IPA は、何万種類もの問題を起こしそうなデータを送り込み、動作の状態から脆弱性を見つける技術と説明する。 【B(不正解)】 ? 攻撃者の視点で侵入を試みる検査です。 実際に攻撃が成功するかを確かめる検査で、大量の異常なデータを機械的に送る手法の名前ではない。 【C(不正解)】 ? 攻撃者をおびき寄せるおとりのシステムです。 攻撃手法の分析などに使うおとりで、自社製品の脆弱性を探す検査ではない。 【D(不正解)】 ? ログを集めて分析する仕組みです。 運用中のログから脅威を見つける仕組みで、出荷前の製品検査の手法ではない。

    出典: 脆弱性対策:ファジング(IPA)

    この問題へのリンク

この分野に出てくる用語(180 語)

2 相コミットメント:複数のデータベースにまたがる処理で、全員に確定の準備ができたかを確かめてから一斉にコミットする方式。

3 層スキーマ:データベースの定義を外部スキーマ・概念スキーマ・内部スキーマの 3 層に分ける考え方。層を分けることでデータの独立性を高める。

ACID 特性:トランザクションが満たすべき原子性・一貫性・独立性・耐久性の 4 つの性質。

ARP:IP アドレスから、同じ LAN にある相手の MAC アドレスを求めるプロトコル。問い合わせはブロードキャストで送る。

CIDR:クラスにとらわれず、IP アドレスのネットワーク部の長さを「/26」のように自由に決める方式。経路の集約にも使う。

CRL:認証局などが署名した、失効した証明書を示す時刻付きのリスト。証明書失効リストともいう。

CSIRT:組織内で、情報セキュリティのインシデントに対応するためのチーム。

CSMA/CA:送信前に回線が空いているかを確かめ、さらに待ち時間を置いて衝突を避けるアクセス制御方式。無線 LAN で使う。

CSMA/CD:送信中に衝突を検知したら、ランダムな時間を待って送り直すアクセス制御方式。有線のイーサネットで使われてきた。

CVSS:脆弱性の深刻度を、ベンダーに依存しない共通の基準で 0.0〜10.0 の数値に表す評価手法。

DBMS:データベースを定義・操作・制御するためのソフトウェア。同時実行制御、障害回復、アクセス制御などの機能を持つ。

DHCP:ネットワークにつないだ機器に、IP アドレスなどの設定を自動で割り当てるプロトコル。

DKIM:電子署名を使って、メールの送信ドメインが正しいかを確かめる送信ドメイン認証の技術。

DMARC:SPF と DKIM の結果をもとに、なりすましメールをどう扱ってほしいかを、ドメインの持ち主が DNS で示す仕組み。

DMZ:外部ネットワークと内部ネットワークの間に設ける区域。外部に公開するサーバを置く。

DNS:ドメイン名と IP アドレスを対応付けて、名前から相手を特定できるようにする仕組み。

DNS キャッシュポイズニング:DNS のキャッシュに偽の対応情報を流し込み、利用者を意図しないサーバへ誘導する攻撃。

DNSSEC:DNS の情報にディジタル署名を付け、発信元の認証と改ざんの検出をできるようにした拡張。通信内容の秘匿はしない。

DoS 攻撃:大量のデータや要求を送り付けて、サーバなどのサービスの提供を妨げる攻撃。

E-R 図:データの対象(エンティティ)と、その間の関連(リレーションシップ)を図で表したもの。

ELT:データを取り出し、先に分析基盤へ書き込んでから、基盤の上で変換する処理。ETL の後ろ 2 つの順序を入れ替えたもの。

ETL:データを取り出し(Extract)、変換し(Transform)、分析基盤に書き込む(Load)処理。変換してから書き込む。

FTP:ファイルの転送に使うプロトコル。命令をやり取りする制御用の接続と、データ用の接続を分けて使う。

GIF:最大 256 色の画像を LZW 方式で可逆圧縮して保存する形式。透明色の指定や、複数の画像を使った簡単なアニメーションができる。

GUI:アイコンやウィンドウなどの図形を表示し、マウスなどで操作する画面の方式。

HMAC:秘密の共有鍵とハッシュ関数を組み合わせて、メッセージ認証符号を作る方式。

HTTP/3:UDP を使う QUIC の上で動く HTTP の版。ストリームが独立し、1 つの損失が他を止めにくい。

HTTPS:HTTP の通信を TLS で暗号化したもの。Web サイトとの通信の盗聴や改ざんを防ぐ。

ICMP:IP の通信で起きた問題を知らせる制御用のプロトコル。IP の一部で、ping の応答や時間超過の通知に使う。

IDS:不正な侵入を検知して知らせるシステム。侵入検知システムともいう。

IMAP:サーバ上のメールボックスを遠隔で扱う受信のプロトコル。メールをサーバに置いたまま複数の端末で読める。

IP アドレス:ネットワーク上の機器を識別するための番号。IPv4 は 32 ビット、IPv6 は 128 ビットで表す。

IPS:不正な侵入を検知し、その通信を遮断して防ぐシステム。侵入防止システムともいう。

IPsec:IP の層で暗号化や認証を行う仕組み。ESP と AH があり、トンネルモードは VPN に使われる。

IPv6:IP アドレスを 32 ビットから 128 ビットに広げた IP の版。経路上のルータはパケットを分割しない。

ISMS:組織が情報セキュリティのリスクを管理し、継続的に改善していくための仕組み。

ISO/IEC 15408:IT 製品やシステムのセキュリティ品質を客観的に評価するための国際評価基準。コモンクライテリアともいう。

JIS Q 27001:情報セキュリティマネジメントシステム(ISMS)の要求事項を定めた規格。ISMS 認証の基準になる。

JPEG:静止画の圧縮方式の規格。主に写真に使われ、非可逆圧縮で高い圧縮率を得られる。

LAN:建物や敷地の中など、限られた範囲で機器をつなぐネットワーク。

MDM:企業などで、スマートフォンやタブレット端末などの携帯端末を安全に管理する仕組み。

MIB:SNMP で管理する機器の情報を、管理対象のオブジェクトとしてまとめた仮想的な情報の集まり。管理情報ベースともいう。

MIME:電子メールで、画像などのテキスト以外のデータや日本語の文字を扱えるようにする規格。

MPEG:動画と音声の圧縮方式の規格群。

MVNO:携帯電話会社(MNO)の通信サービスを利用して移動通信サービスを提供し、無線局を自ら開設・運用しない事業者。

NAPT:IP アドレスに加えてポート番号も変換する技術。1 つのグローバル IP アドレスを複数の端末で共有できる。

NAT:プライベート IP アドレスとグローバル IP アドレスを相互に変換する技術。

NoSQL:関係データベース以外のデータベースの総称。キーバリュー型やドキュメント型などがある。

NTP:ネットワークにつながった機器の時計を正しい時刻に合わせるプロトコル。

OAuth:利用者の許可のもとで、アプリにパスワードではなくアクセストークンで、限られたアクセス権を与える仕組み。

OCSP:証明書が失効していないかを、その場でサーバに問い合わせて確かめるプロトコル。

OLAP:蓄えたデータを多次元に集計し、さまざまな切り口で分析する処理。ドリルダウンやスライスなどの操作がある。

OLTP:受注や入金など、日々の取引をその場で素早く処理するオンライン処理。

OS コマンドインジェクション:Web アプリへの入力を通じて、サーバの OS のコマンドを不正に実行させる攻撃。

OSI 基本参照モデル:通信の機能を、物理層からアプリケーション層までの 7 つの層に分けて整理したモデル。

PCM:アナログの音声信号を標本化・量子化・符号化して、ディジタルデータに変換する方式。

PKI:公開鍵とその持ち主の対応を、認証局が発行する電子証明書で保証する仕組み。

PNG:画素データを可逆圧縮で保存する静止画の形式。フルカラーやパレット(インデックスカラー)、透明度を表すアルファチャンネルに対応する。

POP3:サーバに届いたメールを端末に取り込む受信のプロトコル。取り込んだメールは通常サーバから消す。

RADIUS:ネットワークへの接続装置と認証サーバの間で、認証などの情報をやり取りするプロトコル。

RFP:システムの調達で、発注者が要件や条件を示し、供給者に提案を求める文書。

S/MIME:メールにディジタル署名と暗号化を行う規格。署名で改ざん検出や否認防止、暗号化で秘匿ができる。

SDN:ネットワーク機器の転送の動きを、ソフトウェアから集中して制御する考え方。OpenFlow が代表例。

SIEM:多数の機器のログを集めて分析し、複数の機器にまたがる出来事の関連から脅威を見つける仕組み。

SLA:サービスの提供者と利用者の間で、サービスの内容と達成すべき水準を取り決めた合意。

SMTP:電子メールを送信・転送するためのプロトコル。

SNMP:ネットワークにつながった機器の状態を監視・管理するためのプロトコル。

SPF:送信元メールサーバの IP アドレスを DNS で確認し、送信元ドメインの詐称を見破る仕組み。

SQL インジェクション:入力欄に不正な SQL の断片を入れ、データベースを不正に操作する攻撃。

SSID:無線 LAN のアクセスポイントを見分けるためのネットワーク名。電波の届く範囲なら誰でも見られる。

TCP:通信相手との接続を確立し、再送や順序の制御でデータを確実に届けるトランスポート層のプロトコル。

TCP/IP:インターネットで使われる通信プロトコルの体系。TCP と IP を中心に構成される。

TLS:通信相手の認証と通信内容の暗号化を行うプロトコル。HTTPS などで使われる。

UDP:接続を確立せずにデータを送るトランスポート層のプロトコル。信頼性より即時性を重視する通信に使う。

VLAN:物理的な接続とは関係なく、論理的に LAN を分割する技術。

VPN:インターネットなどを通して、暗号化などにより拠点の間を専用線のようにつなぐ技術。

WAF:Web アプリケーションへの通信を検査し、SQL インジェクションなどの攻撃を防ぐ仕組み。

WAN:離れた拠点どうしを、通信事業者の回線などを使って結ぶ広域のネットワーク。

WBS:プロジェクトの成果物や作業を、管理しやすい大きさまで階層的に分解したもの。

WCAG:W3C が定めるウェブコンテンツのアクセシビリティの指針。知覚可能・操作可能・理解可能・堅牢の 4 原則と、A・AA・AAA の 3 つの適合レベルがある。

WPA3:無線 LAN の暗号化方式の一つ。WPA2 より強固な暗号化方式を使える。

アーラン:電話回線などの呼量の単位。観測時間の中で回線が使われた時間の合計を、観測時間で割って求める。

アクセシビリティ:年齢や障害の有無などにかかわらず、誰もが情報やサービスを利用できること。ウェブでは JIS X 8341-3 や WCAG が基準になる。

インデックス:表の検索を速くするための索引。B-tree やハッシュなどの種類があり、増やしすぎると更新が遅くなる。

キーバリュー型データベース:一意なキーと値の組でデータを持つデータベース。キーを指定した読み書きが速く、セッション情報などに使う。

グラフデータベース:データをノード(点)とエッジ(線)で表し、関係をたどる処理が得意なデータベース。SNS や推薦などに使う。

クロスサイトスクリプティング:Web ページに悪意のあるスクリプトを埋め込み、閲覧者のブラウザで実行させる攻撃。

クロスサイトリクエストフォージェリ:ログイン中の利用者に罠のページを開かせ、本人の意図しない処理を Web サイトで実行させる攻撃。

コミット:トランザクションの処理を確定させ、更新内容をデータベースに反映すること。

サブネットマスク:IP アドレスのうち、ネットワークを表す部分とホストを表す部分を区別するための値。

ジャーナルファイル:データベースの更新前・更新後の内容を記録したファイル。障害回復のロールバックやロールフォワードに使う。

シングルサインオン:1 回の認証で、複数のシステムやサービスを使えるようにする仕組み。

スイッチングハブ:受け取ったフレームの宛先 MAC アドレスを見て、宛先がつながるポートだけに転送する装置。データリンク層で動く。

スター型:各端末を中央の集線装置に 1 本ずつつなぐネットワークの形。中央の装置が止まると全体に影響する。

セッションハイジャック:利用者と Web サーバとの通信を、利用者以外の者が乗っ取る攻撃。

ゼロデイ攻撃:脆弱性が見つかってから、メーカーの修正プログラムが配布される前に、その脆弱性を突いて行う攻撃。

ソーシャルエンジニアリング:人の心理的な隙や不注意につけ込み、パスワードなどの情報を不正に入手する手口。

ソルト:パスワードからハッシュ値などを作るときに加えるランダムな値。同じパスワードでも違う値になり、事前計算の攻撃を難しくする。

チェックポイント:メモリ上の更新内容を定期的にディスクへ書き出す時点。障害回復ではこの時点を起点にして処理量を減らす。

チャレンジレスポンス認証:サーバが毎回違う値(チャレンジ)を送り、端末が秘密の情報と組み合わせて計算した値を返す認証方式。秘密の情報は回線に流れない。

ディジタル署名:送信者が秘密鍵で作った署名を受信者が公開鍵で検証し、送信者の確認と改ざんの検出を行う技術。

ディレクトリトラバーサル:「../」などでファイルの場所をたどり、公開していないサーバ内のファイルを読み出す攻撃。

データウェアハウス:業務システムなどのデータを、分析のために整えて時系列で蓄える仕組み。保存する前に構造(スキーマ)を決める。

データディクショナリ:データ項目の名前・意味・型などのメタデータを集めて管理する辞書。項目名の不統一を防ぐのに役立つ。

データレイク:さまざまな形式のデータを、加工せずにそのままの形で蓄えておく保存場所。

デッドロック:複数の処理が互いに相手の確保した資源の解放を待ち続け、どれも先へ進めなくなる状態。

トランザクション:データベースに対する一連の処理を、分けられない 1 つのまとまりとして扱う単位。

ハイブリッド暗号:データは処理の速い共通鍵で暗号化し、その共通鍵を受信者の公開鍵で暗号化して渡す方式。

パケット交換:データを小さな単位(パケット)に分けて送り、1 本の回線を多くの通信で共有する交換方式。

パスワードリスト攻撃:あるサービスから漏れた ID とパスワードを使い、別のサービスへの不正ログインを試す攻撃。

ハッシュ関数:任意の長さのデータから固定長の値(ハッシュ値)を作る関数。改ざんの検出などに使う。

ハニーポット:攻撃者をわざと侵入させ、攻撃手法の分析などに使うおとりのシステム。

ビュー:1 つ以上の表から導出した仮想的な表。名前を付けて、表と同じように検索できる。

ヒューリスティック評価:専門家が、使いやすさに関する経験則(ヒューリスティクス)に照らして画面などの問題点を洗い出す評価手法。

ファイアウォール:ネットワークの境界で、通信を許可するか遮断するかを規則に従って判断する仕組み。

ファジング:問題を起こしそうなデータを大量に送り込み、ソフトウェアの動作の状態から脆弱性を見つける技術。

フィッシング:実在する組織を装った偽のメールや Web サイトで、ID やパスワードなどをだまし取る手口。

フェールセーフ:故障や誤りが起きたとき、システムが安全な側に動作するように設計する考え方。

フォールスネガティブ:異常なものを正常と判定して見逃す誤り。検知漏れ(偽陰性)ともいう。

フォールスポジティブ:正常なものを異常と判定してしまう誤り。誤検知(偽陽性)ともいう。

フォールトトレラント:一部の構成要素が故障しても、システム全体として必要な機能を保ち続けられるようにする設計の考え方。

プライベート IP アドレス:組織の中だけで自由に使える IP アドレス。IPv4 では 10.0.0.0/8・172.16.0.0/12・192.168.0.0/16 の範囲(RFC 1918)。

ブルートフォース攻撃:考えられるパスワードなどの候補を、すべて順に試す攻撃。

プレースホルダ:SQL 文の変数部分を記号にしておき、後から値を機械的に割り当てる方法。SQL インジェクションの根本的な対策。

プロキシサーバ:内部の利用者に代わって外部のサーバへ接続するサーバ。通信の中継やアクセス制限、キャッシュに使う。

ベクターデータ:図形を点の座標と線・曲線・塗りの情報で表すデータ。拡大・縮小しても輪郭がなめらかなまま保てる。

ペネトレーションテスト:攻撃者と同じ視点で実際に攻撃を試み、攻撃が成功するかを確かめる検査。

ポート番号:TCP や UDP で、通信相手のアプリケーションのサービスを区別する 16 ビットの番号。

マルウェア:ウイルスやワームなど、悪意をもって作られたソフトウェアの総称。

メタデータ:データの名前・意味・型・作成日・格納場所など、データそのものについて説明するデータ。

メッセージ認証符号:共通鍵とメッセージから作る値。メッセージが改ざんされていないことの確認に使う。

ユーザビリティ:製品やシステムの使いやすさ。利用者が目的を有効に、効率よく、満足して達成できる度合い。

ユニバーサルデザイン:年齢や障害の有無などにかかわらず、できるだけ多くの人が使いやすいように設計する考え方。

ラスターデータ:画像を画素(ピクセル)の並びで表すデータ。写真の表現に向くが、拡大すると輪郭が粗くなる。

ランサムウェア:データを暗号化するなどして使えなくし、元に戻すことと引換えに金銭を要求するマルウェア。

リスク移転:保険への加入や外部サービスの利用などで、損失の負担を他社などへ移す対応。リスク共有の一つ。

リスク回避:リスクの原因となる活動を止めたり別の方法に変えたりして、リスクが起こる可能性を取り去る対応。

リスク低減:脆弱性に対策をして、脅威が起こる可能性や影響を下げる対応。

リスク保有:影響が小さい、対策の費用が損害額を上回るなどの理由で、対策せずにリスクを受け入れる対応。

リバースプロキシ:外部からの要求を受け付け、内部のサーバに代わって中継するサーバ。負荷分散や内部サーバの隠ぺいに使う。

ルータ:ネットワーク層で動作し、IP アドレスをもとにパケットの転送先を決める装置。

レプリケーション:データベースの複製を別のサーバや拠点に作り、更新を同期して保つ仕組み。

ロールバック:障害などのとき、トランザクションの更新を取り消して開始前の状態に戻すこと。

ロールフォワード:障害の後、バックアップにログの更新後の情報を順に反映して、障害直前の状態まで回復すること。

可逆圧縮:圧縮したデータから、元のデータを 1 ビットも違わずに復元できる圧縮方式。PNG や ZIP が使う。

可用性:認められた人が、必要なときに情報やシステムを使える状態を確保すること。情報セキュリティの要素の一つ。

回線交換:通信の間、相手との経路を専有して確保する交換方式。品質は安定するが、回線の利用効率は低い。

外部キー:ほかの表の主キーを参照する列。表と表の関係を表し、参照の整合性を保つ。

完全性:情報が正確で、改ざんや欠落がない状態を確保すること。情報セキュリティの要素の一つ。

関係データベース:データを行と列からなる表(関係)で表し、表どうしを値で関連づけるデータベース。SQL で操作する。

機密性:認められた人だけが情報を利用できる状態を確保すること。情報セキュリティの要素の一つ。

共通鍵暗号方式:暗号化と復号に同じ鍵を使う暗号方式。処理は速いが、鍵を安全に共有する必要がある。

共有ロック:データを読むときにかけるロック。共有ロックどうしは同時にかけられるが、専有ロックとは両立しない。

結合:2 つの表を共通の列の値で結び付け、1 つの表を作る関係演算。

公開鍵暗号方式:公開鍵と秘密鍵の対を使う暗号方式。公開鍵で暗号化したデータは、対応する秘密鍵でしか復号できない。

射影:表から特定の列だけを取り出す関係演算。

主キー:表の中の各行を一意に識別するための列、または列の組。

集約関数:複数の行から 1 つの値を求める SQL の関数。COUNT・SUM・AVG・MAX・MIN など。WHERE 句には書けない。

情報セキュリティポリシー:情報の機密性・完全性・可用性を維持するために定める、組織の方針や行動指針をまとめたもの。

人間中心設計:利用者と利用の状況を理解し、要求を明確にして設計し、利用者による評価で改善を繰り返す設計の進め方。ISO 9241-210(JIS Z 8530)が定める。

推移関数従属:主キーで決まる項目を介して、さらに別の項目が決まる関係。なくすと第 3 正規形になる。

正規化:関係データベースの表を、データの重複や更新時の矛盾が起きないように分割・整理すること。

生体認証:指紋や顔など、一人一人異なる体の特徴を使って本人を確かめる認証技術。

脆弱性診断:システム全体を網羅的に調べ、攻撃のきっかけになりうる弱点を見つける検査。

専有ロック:データを更新するときにかけるロック。かかっている間、他の処理は共有ロックも専有ロックもかけられない。

全二重:送信と受信を同時に行える通信方式。電話のように双方向へ同時に送れる。

他人受入率:生体認証で、システムが他人を正規の利用者と誤って認める確率。FAR ともいう。

多要素認証:知識・所持・生体などの要素のうち、2 種類以上を組み合わせて本人を確認する方法。

耐タンパ性:暗号処理などを行う装置やソフトウェアが、外部からの解読攻撃に耐える性質。

中間者攻撃:通信している当事者の間に第三者が割り込み、盗み見や書き換えなどの不正を行う攻撃。

認証局:公開鍵の持ち主を確認し、電子証明書を発行する機関。

排他制御:複数の処理が同じデータを同時に更新して矛盾が起きないよう、ロックなどで処理の順番を制御すること。

半二重:双方向に送れるが、同時には送れず送受信を交互に切り替える通信方式。

非可逆圧縮:人が気づきにくい情報を捨てて圧縮率を上げる方式。元のデータには完全には戻らない。JPEG や MPEG が使う。

標的型攻撃:特定の組織を狙い、機密情報やアカウント情報などを盗もうとする攻撃。

不正のトライアングル:人が不正を働くのは「動機・プレッシャー」「機会」「正当化」の 3 つがそろったときとする考え方。

部分関数従属:主キーが複数の項目からなるとき、主キーではない項目がその一部だけで決まる関係。なくすと第 2 正規形になる。

副問合せ:SQL 文の中に入れた別の SELECT 文。先に求めた結果を条件などに使える。

本人拒否率:生体認証で、システムが正規の利用者を他人と誤って拒む確率。FRR ともいう。

無線 LAN:電波を使って端末をつなぐ LAN。IEEE 802.11 の規格に基づき、Wi-Fi とも呼ばれる。

用語集で全部の用語を見る →

独学の次に、講座で体系立てて学びたい人へ

この問題集は独学用です。IT の基礎から講師つきで体系立てて学びたい人には、資格や IT の講座がそろうスクールも選択肢になります。

本ページは広告・アフィリエイトプログラムを利用しており、リンク経由でのお申し込み・購入により当サイトに収益が発生することがあります。ただし、ランキング・評価・掲載内容は広告費や報酬の有無に関わらず編集部の独自基準で決定しており、広告主からの指示により内容を変更することはありません。

ヒューマンアカデミー(資格・IT/Webスクール)PR

IT・Webデザイン・資格まで幅広い講座。生成AI/DX講座はリスキリング補助金の対象

ヒューマンアカデミー(資格・IT/Webスクール)の広告無料で講座資料を探す →

まずは無料ではじめられます。リンク先は公式サイトです。

このサービスの解説記事を読む →